Project

General

Profile

Feature #39093

mgr/orchestrator: add `ceph orchestrator wait`

Added by Sebastian Wagner over 1 year ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Reviewed:
Affected Versions:
Pull request ID:

Description

Add ceph orchestrator wait that waits for unfinished completions
Replace self._orchestrator_wait([completion]) with yield
Signed-off-by: Sebastian Wagner

The cli then looks like so:

$ ceph 'orchestrator' service ls --wait=false
queued.
$ ceph 'orchestrator' osd create localhost:/dev/xxx --wait=false
queued.
$ ceph orchestrator wait
<read op>
None ceph-mgr localhost None None None
None ceph-mgr localhost None None None
None ceph-mgr localhost None None None
None ceph-mon localhost None None None
None ceph-mon localhost None None None
None ceph-mon localhost None None None
None ceph-osd localhost None None None
None ceph-osd localhost None None None
None ceph-osd localhost None None None
None ceph-osd localhost None None None
create_osds, args=(<orchestrator.DriveGroupSpec object at 0x7f264d4b01d0>, ['localhost']), kwargs={}
None


Related issues

Related to Orchestrator - Bug #37514: mgr CLI commands block one another (indefinitely if the orchestrator CLI gets stuck in wait) Can't reproduce

History

#1 Updated by Sage Weil 9 months ago

  • Project changed from mgr to Orchestrator
  • Category deleted (orchestrator)

#2 Updated by Sebastian Wagner 9 months ago

  • Related to Bug #37514: mgr CLI commands block one another (indefinitely if the orchestrator CLI gets stuck in wait) added

#3 Updated by Sebastian Wagner 7 months ago

  • Status changed from Fix Under Review to Rejected

out of scope for now.

Also available in: Atom PDF