Project

General

Profile

Bug #39000

rgw: beast endpoint doesn't set a default port

Added by Abhishek Lekshmanan 5 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
03/28/2019
Due date:
% Done:

0%

Source:
Tags:
beast
Backport:
nautilus, mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

if endpoint is specified without a trailing port, we don't seem to set this to the default port. Also specifying port= argument always binds a ipv4 address with the port, so a ipv6 endpoint(without a port) and a port argument will bind a ipv4 with port argument and ipv6 without a port.


Related issues

Copied to rgw - Backport #39048: nautilus: rgw: beast endpoint doesn't set a default port Resolved
Copied to rgw - Backport #39049: mimic: rgw: beast endpoint doesn't set a default port Resolved

History

#1 Updated by Abhishek Lekshmanan 5 months ago

  • Status changed from New to In Progress
  • Assignee set to Abhishek Lekshmanan
  • Tags set to beast
  • Pull request ID set to 27242

#2 Updated by Casey Bodley 5 months ago

  • Status changed from In Progress to Pending Backport

#3 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #39048: nautilus: rgw: beast endpoint doesn't set a default port added

#4 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #39049: mimic: rgw: beast endpoint doesn't set a default port added

#5 Updated by Nathan Cutler 3 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF