Project

General

Profile

Bug #39

Re-examine PaxosServiceMessage::get_session() and use

Added by Greg Farnum almost 11 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Monitor
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I got a crash while testing the new libatomic-based atomic_t, but I don't think it could have been caused by the change. Segfault on a null-valued Session.

History

#1 Updated by Greg Farnum almost 11 years ago

  • Category set to Monitor
  • Status changed from New to In Progress
  • Assignee set to Greg Farnum
  • Start date set to 04/14/2010

#2 Updated by Sage Weil almost 11 years ago

  • Target version set to v0.20

#3 Updated by Greg Farnum almost 11 years ago

  • Status changed from In Progress to Closed

Can't reproduce. The code actually had a bad memory leak at the time and was causing the machine to run out of memory; it's possible that a call to new returned NULL and the first deref crashed out. Certainly everything looks fine.

Also available in: Atom PDF