Project

General

Profile

Bug #38996

cephfs-shell: ls command produces error: no "colorize" attribute found error

Added by Varsha Rao 5 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Administration/Usability
Target version:
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
cephfs-shell
Labels (FS):
Pull request ID:

Description

Even though the package colorize-0.3.4-15.fc29.noarch is already installed.
The following error is produced.

CephFS:~/>>> ls
'CephFSShell' object has no attribute 'colorize'
Traceback (most recent call last):
  File "./../src/tools/cephfs/cephfs-shell", line 367, in onecmd
    res = Cmd.onecmd(self, line)
  File "/usr/local/lib/python3.7/site-packages/cmd2-0.9.11-py3.7.egg/cmd2/cmd2.py", line 1992, in onecmd
    stop = func(statement)
  File "/usr/local/lib/python3.7/site-packages/cmd2-0.9.11-py3.7.egg/cmd2/cmd2.py", line 252, in cmd_wrapper
    return func(cmd2_instance, args)
  File "./../src/tools/cephfs/cephfs-shell", line 593, in do_ls
    values.append(self.colorize(path + '/', 'blue'))
AttributeError: 'CephFSShell' object has no attribute 'colorize'


Related issues

Copied to fs - Backport #39197: nautilus: cephfs-shell: ls command produces error: no "colorize" attribute found error Resolved

History

#1 Updated by Patrick Donnelly 5 months ago

  • Status changed from New to Duplicate

#2 Updated by Patrick Donnelly 5 months ago

  • Duplicates Bug #38122: Error ceph fs status added

#3 Updated by Patrick Donnelly 5 months ago

  • Duplicates deleted (Bug #38122: Error ceph fs status)

#4 Updated by Patrick Donnelly 5 months ago

  • Subject changed from ls command produces error: no "colorize" attribute found error to cephfs-shell: ls command produces error: no "colorize" attribute found error
  • Status changed from Duplicate to Verified
  • Assignee set to Varsha Rao
  • Priority changed from Normal to Urgent
  • Target version set to v15.0.0
  • Start date deleted (03/28/2019)
  • Source set to Development
  • Backport set to nautilus

I just ran into this issue. Sorry for assuming it's a duplicate.

It looks like this was caused by the cmd2 module deleting the colorize modules in 0.9.7 release: https://github.com/python-cmd2/cmd2/releases/tag/0.9.7

Varsha, can you look into how to fix this?

#5 Updated by Varsha Rao 4 months ago

Patrick Donnelly wrote:

I just ran into this issue. Sorry for assuming it's a duplicate.

It looks like this was caused by the cmd2 module deleting the colorize modules in 0.9.7 release: https://github.com/python-cmd2/cmd2/releases/tag/0.9.7

Varsha, can you look into how to fix this?

I have submitted a patch for it.

#6 Updated by Patrick Donnelly 4 months ago

  • Status changed from Verified to Need Review
  • Pull request ID set to 27427

#7 Updated by Patrick Donnelly 4 months ago

  • Status changed from Need Review to Pending Backport

#8 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #39197: nautilus: cephfs-shell: ls command produces error: no "colorize" attribute found error added

#9 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF