Project

General

Profile

Cleanup #38948

mgr/dashboard: Replace OSD histogram graphs with something more insightful

Added by Lenz Grimmer over 3 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Component - OSDs
Target version:
% Done:

0%

Tags:
usability
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

Currently, the OSD details contain a tab "Histogram" that shows a feature that was ported from the initial dashboard without any modification.

It displays two big red blocks labeled "Writes" and "Reads" as follows:

It's not entirely clear what kind of information these blocks are supposed to visualize and if they are actual "Histograms".
It may make sense to reconsider the design of these widgets with something more useful. Maybe a heat map, combining reads and writes into once graph?

Screenshot_2019-03-27 Ceph.png View (62.2 KB) Lenz Grimmer, 03/27/2019 12:48 PM


Related issues

Duplicates Dashboard - Feature #26954: mgr/dashboard: Remove Histogram component Resolved

History

#1 Updated by Lenz Grimmer over 3 years ago

  • Status changed from New to Duplicate

Duplicate of #26954 (I somehow missed that one)

#2 Updated by Lenz Grimmer over 3 years ago

  • Duplicates Feature #26954: mgr/dashboard: Remove Histogram component added

#3 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 138 to Component - OSDs

Also available in: Atom PDF