Project

General

Profile

Bug #38833

ceph-volume does not allow the use of removable disks

Added by Alejandro Bonilla about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

While attempting to deploy using ceph-volume, the drives are marked as removable and therefore not usable.

  1. ceph-volume inventory /dev/sdb

====== Device report /dev/sdb ======

path                      /dev/sdb
available True
rejected reasons
removable 1
ro 0
vendor VendorCo
model ProductCode
sas address
rotational 1
scheduler mode cfq
human readable size 14.65 GB

The use case here is to allow implementing Ceph on Raspberry Pi envs that are small/demo.

Should ceph-volume allow the option to bypass any protection of removable disks?

History

#1 Updated by Greg Farnum about 2 years ago

  • Project changed from Ceph to ceph-volume
  • Category deleted (common)

#2 Updated by Alfredo Deza about 2 years ago

It is not possible to disable that internal check from ceph-volume, however, the workaround in your case would be to create the LV on that removable device and just create the OSD there vs. trying to use the disk directly.

#3 Updated by Alfredo Deza about 2 years ago

  • Status changed from New to Rejected

#4 Updated by Alejandro Bonilla about 2 years ago

I'd like to have this tracker re-opened since it's not a how-to question nor was I looking for a workaround. ceph-volume brings a regression which is the inability to utilize removable devices directly, therefore it should be tracked and when possible, fixed.

#5 Updated by Alfredo Deza about 2 years ago

I closed the ticket because it is something that ceph-volume is not going to allow, or make it configurable. ceph-volume concentrates in production-only scenarios, and using removable disks is not something that we would consider supporting.

As I mentioned, if you must use removable devices, you can pre-create the logical volumes and then pass those onto ceph-volume.

#6 Updated by Jan Fajerski about 2 years ago

@Alfredo what exactly is the technical argument against making this a cli argument?

#7 Updated by Alfredo Deza about 2 years ago

By supporting production-only features, we allow narrowing the scope of both work to be done and bugs to fix. A prime example of this was ceph-disk's ability to
deploy OSDs to directories, which was meant to be a helpful feature for developers to easily test OSDs, and then it became a way users thought was a supported/recommended way to launch an OSD (it wasn't).

The amount of work put into developing features for it, and bugs that had to be fixed was tremendous. At some point even ceph-ansible had support for it.

So, again, like I mentioned: if it isn't a feature/fix that makes sense for a production environment, we are not going to consider it - even more so if there is a way to accomplish what is wanted here (LVs can be created on top of removable disks)

Also available in: Atom PDF