Project

General

Profile

Bug #38811

rgw: read not exists null version success and return empty data

Added by Tianshan Qu 6 months ago. Updated 24 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
03/19/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous mimic nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

steps
1.enable bucket versioning
2.PUT obj (got version XXX)
3.GET obj with version_id=null (return success and have no data)

after PUT one version, head object will create with only olh info, so GET null version return wrong.


Related issues

Copied to rgw - Backport #38907: mimic: rgw: read not exists null version success and return empty data Resolved
Copied to rgw - Backport #38908: luminous: rgw: read not exists null version success and return empty data Resolved
Copied to rgw - Backport #38909: nautilus: rgw: read not exists null version success and return empty data Resolved

History

#2 Updated by Matt Benjamin 6 months ago

  • Status changed from New to Need Review

#3 Updated by Casey Bodley 6 months ago

  • Assignee set to Casey Bodley

#4 Updated by Casey Bodley 6 months ago

  • Status changed from Need Review to Testing
  • Backport set to luminous mimic nautilus

#5 Updated by Casey Bodley 6 months ago

s3test pr will also need backports https://github.com/ceph/s3-tests/pull/262

#6 Updated by Casey Bodley 6 months ago

  • Status changed from Testing to Pending Backport

#7 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #38907: mimic: rgw: read not exists null version success and return empty data added

#8 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #38908: luminous: rgw: read not exists null version success and return empty data added

#9 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #38909: nautilus: rgw: read not exists null version success and return empty data added

#10 Updated by Nathan Cutler 24 days ago

  • Status changed from Pending Backport to Resolved

Having been run with --resolve-parent, the script "backport-create-issue" set the status of this issue to "Resolved" because it determined all backport issues are in status Resolved.

Also available in: Atom PDF