Project

General

Profile

Bug #38803

qa: test_sessionmap assumes simple messenger

Added by Patrick Donnelly 5 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
03/18/2019
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
nautilus
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa, task(easy)
Pull request ID:

Description

Failure: Test failure: test_mount_conn_close (tasks.cephfs.test_sessionmap.TestSessionMap)
4 jobs: ['3730691', '3730791', '3730841', '3730638']
suites intersection: ['clusters/1-mds-4-client.yaml', 'conf/{client.yaml', 'kcephfs/recovery/{begin.yaml', 'kclient/{mount.yaml', 'log-config.yaml', 'mds.yaml', 'mon.yaml', 'ms-die-on-skipped.yaml}}', 'osd-asserts.yaml', 'osd.yaml}', 'overrides/{distro/random/{k-testing.yaml', 'overrides/{frag_enable.yaml', 'tasks/sessionmap.yaml}', 'whitelist_health.yaml', 'whitelist_wrongly_marked_down.yaml}']
suites union: ['clusters/1-mds-4-client.yaml', 'conf/{client.yaml', 'kcephfs/recovery/{begin.yaml', 'kclient/{mount.yaml', 'log-config.yaml', 'mds.yaml', 'mon.yaml', 'ms-die-on-skipped.yaml}}', 'objectstore-ec/bluestore-comp-ec-root.yaml', 'objectstore-ec/bluestore-comp.yaml', 'objectstore-ec/bluestore-ec-root.yaml', 'objectstore-ec/filestore-xfs.yaml', 'osd-asserts.yaml', 'osd.yaml}', 'overrides/{distro/random/{k-testing.yaml', 'overrides/{frag_enable.yaml', 'supported$/{centos_latest.yaml}}', 'supported$/{ubuntu_16.04.yaml}}', 'tasks/sessionmap.yaml}', 'whitelist_health.yaml', 'whitelist_wrongly_marked_down.yaml}']

From: /ceph/teuthology-archive/pdonnell-2019-03-16_00:15:50-kcephfs-wip-pdonnell-testing-20190315.213331-distro-basic-smithi


Related issues

Related to fs - Bug #38676: qa: src/common/Thread.cc: 157: FAILED ceph_assert(ret == 0) Resolved
Copied to fs - Backport #39430: nautilus: qa: test_sessionmap assumes simple messenger Resolved

History

#1 Updated by Patrick Donnelly 5 months ago

  • Related to Bug #38676: qa: src/common/Thread.cc: 157: FAILED ceph_assert(ret == 0) added

#2 Updated by Patrick Donnelly 5 months ago

  • Backport deleted (nautilus,mimic,luminous)

#3 Updated by Patrick Donnelly 5 months ago

  • Status changed from Verified to In Progress

#4 Updated by Patrick Donnelly 5 months ago

  • Status changed from In Progress to Need Review
  • Pull request ID set to 27415

#5 Updated by Patrick Donnelly 5 months ago

  • Status changed from Need Review to Resolved

#6 Updated by Patrick Donnelly 4 months ago

  • Status changed from Resolved to Pending Backport
  • Backport set to nautilus

Because of the fix to http://tracker.ceph.com/issues/38676 is in nautilus, this must be backported too.

#7 Updated by Nathan Cutler 4 months ago

  • Copied to Backport #39430: nautilus: qa: test_sessionmap assumes simple messenger added

#8 Updated by Nathan Cutler 2 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF