Project

General

Profile

Bug #38636

Inline data compatibly check in Locker::issue_caps is buggy

Added by Zheng Yan 9 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature:

Description

    Session *session = mds->get_session(it->first);
    if (in->inode.inline_data.version != CEPH_INLINE_NONE &&
        !(session &&
          session->get_connection() &&
          session->get_connection()->has_feature(CEPH_FEATURE_MDS_INLINE_DATA)))
      allowed &= ~(CEPH_CAP_FILE_RD | CEPH_CAP_FILE_WR);

Session->get_connection() can be null for imported session. No idea how to fix this (luminous, mimic also need fix) unless obsolete inline data feature


Related issues

Duplicates fs - Bug #38652: mds|kclient: MDS_CLIENT_LATE_RELEASE warning caused by inline bug on RHEL 7.5 Resolved

History

#1 Updated by Patrick Donnelly 9 months ago

  • Status changed from New to Duplicate

#2 Updated by Patrick Donnelly 9 months ago

  • Duplicates Bug #38652: mds|kclient: MDS_CLIENT_LATE_RELEASE warning caused by inline bug on RHEL 7.5 added

#3 Updated by Zheng Yan 9 months ago

  • Pull request ID set to 26881

Also available in: Atom PDF