Project

General

Profile

Bug #38629

ceph_dencoder.cc: c++: internal compiler error: Killed (program cc1plus)

Added by Sebastian Wagner over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
build
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
QA
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

my master is on b954e3d8b13ff0ab9fce973eacf54e013228df91

while building this revision, I got:

[ 88%] Building CXX object src/tools/ceph-dencoder/CMakeFiles/ceph-dencoder.dir/ceph_dencoder.cc.o
cd /build/ceph-14.1.0-435-g618ab58/obj-x86_64-linux-gnu/src/tools/ceph-dencoder && /usr/bin/c++  -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D__linux__ -isystem /build/ceph-14.1.0-435-g618ab58/obj-x86_64-linux-gnu/boost/include -I/build/ceph-14.1.0-435-g618ab58/obj-x86_64-linux-gnu/src/include -I/build/ceph-14.1.0-435-g618ab58/src -isystem /build/ceph-14.1.0-435-g618ab58/obj-x86_64-linux-gnu/include -I/usr/include/nss -I/usr/include/nspr -isystem /build/ceph-14.1.0-435-g618ab58/src/xxHash -isystem /build/ceph-14.1.0-435-g618ab58/src/rapidjson/include -isystem /build/ceph-14.1.0-435-g618ab58/src/spdk/include -isystem /build/ceph-14.1.0-435-g618ab58/obj-x86_64-linux-gnu/src/dpdk/include -isystem /build/ceph-14.1.0-435-g618ab58/src/rocksdb/include -I/build/ceph-14.1.0-435-g618ab58/src/dmclock/src -I/build/ceph-14.1.0-435-g618ab58/src/dmclock/support/src -isystem /build/ceph-14.1.0-435-g618ab58/src/rgw/../rapidjson/include  -g -O2 -fdebug-prefix-map=/build/ceph-14.1.0-435-g618ab58=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -Wall -Wtype-limits -Wignored-qualifiers -Winit-self -Wpointer-arith -Werror=format-security -fno-strict-aliasing -fsigned-char -Wno-unknown-pragmas -rdynamic -g -O2 -fdebug-prefix-map=/build/ceph-14.1.0-435-g618ab58=. -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -ftemplate-depth-1024 -Wnon-virtual-dtor -Wno-unknown-pragmas -Wno-ignored-qualifiers -Wstrict-null-sentinel -Woverloaded-virtual -fno-new-ttp-matching -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fdiagnostics-color=auto -fno-builtin-malloc -fno-builtin-calloc -fno-builtin-realloc -fno-builtin-free -fPIE   -DHAVE_CONFIG_H -D__CEPH__ -D_REENTRANT -D_THREAD_SAFE -D__STDC_FORMAT_MACROS -march=core2 -std=c++1z -fno-var-tracking-assignments -o CMakeFiles/ceph-dencoder.dir/ceph_dencoder.cc.o -c /build/ceph-14.1.0-435-g618ab58/src/tools/ceph-dencoder/ceph_dencoder.cc
c++: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.
src/tools/ceph-dencoder/CMakeFiles/ceph-dencoder.dir/build.make:66: recipe for target 'src/tools/ceph-dencoder/CMakeFiles/ceph-dencoder.dir/ceph_dencoder.cc.o' failed
make[4]: *** [src/tools/ceph-dencoder/CMakeFiles/ceph-dencoder.dir/ceph_dencoder.cc.o] Error 4
make[4]: Leaving directory '/build/ceph-14.1.0-435-g618ab58/obj-x86_64-linux-gnu'
CMakeFiles/Makefile2:8884: recipe for target 'src/tools/ceph-dencoder/CMakeFiles/ceph-dencoder.dir/all' failed
  1. shaman: https://shaman.ceph.com/builds/ceph/wip-swagner-testing/618ab5825c33666af7947c60d604df4f123eaa0c/default/145500/
  2. jenkins: https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=bionic,DIST=bionic,MACHINE_SIZE=huge/18467/
  3. log: https://jenkins.ceph.com/job/ceph-dev-new-build/ARCH=x86_64,AVAILABLE_ARCH=x86_64,AVAILABLE_DIST=bionic,DIST=bionic,MACHINE_SIZE=huge/18467//consoleFull

Related issues

Duplicates Ceph - Bug #39595: Compile error: ceph-dencoder: invalid operands (*UND* and .gcc_except_table sections) for `-' Resolved 05/06/2019

History

#1 Updated by Brad Hubbard over 1 year ago

Hi Sebastian,

We saw a lot of these internal compiler errors today but we believe it was a resource problem on at least one of the build machines. I've resubmitted your build 618ab5825c33666af7947c60d604df4f123eaa0c as https://shaman.ceph.com/builds/ceph/wip-badone-testing/c6faca01a225dbdd9b6082ac9f71e5976cea69f0 (since you can't build the same commit twice on shaman). Let's see how that goes.

#2 Updated by Brad Hubbard over 1 year ago

  • Project changed from RADOS to Ceph
  • Category changed from Tests to build

#3 Updated by Brad Hubbard over 1 year ago

  • Status changed from New to Closed
  • Assignee set to Brad Hubbard

Seems to have built OK. I'm going to close this but please feel free to reopen it if you see the same issue again.

#4 Updated by Kefu Chai over 1 year ago

  • Duplicates Bug #39595: Compile error: ceph-dencoder: invalid operands (*UND* and .gcc_except_table sections) for `-' added

Also available in: Atom PDF