Project

General

Profile

Bug #38627

insights is not Python 3 compatible

Added by Sebastian Wagner over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
QA
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

/src/scripts/run_mypy.sh revealed some type errors in the insights module:

pybind/mgr/insights/module.py: note: In member "do_prune_health" of class "Module":
pybind/mgr/insights/module.py:298: error: Name 'errno' is not defined
pybind/mgr/insights/module.py: note: In member "testing_set_now_time_offset" of class "Module":
pybind/mgr/insights/module.py:310: error: Name 'long' is not defined
pybind/mgr/insights/module.py: note: In member "handle_command" of class "Module":
pybind/mgr/insights/module.py:320: error: Name 'cmd' is not defined

Especially "Name 'long' is not defined" looks like a Python 3 incompatibility

History

#1 Updated by Kefu Chai over 1 year ago

  • Assignee set to Kefu Chai

#2 Updated by Kefu Chai over 1 year ago

  • Status changed from New to Fix Under Review
  • Pull request ID set to 27925

#3 Updated by Kefu Chai over 1 year ago

  • Pull request ID changed from 27925 to 27926

#4 Updated by Kefu Chai over 1 year ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF