Project

General

Profile

Bug #38601

the dashboard iscsi throw ERROR 500

Added by 一帆 师 over 3 years ago. Updated over 1 year ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Category:
Component - iSCSI
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

I run an iscsi gateway in my env,it works well,

and my rbd-gateway-api is http://192.168.6.3:5000

but after i add it to the dashboard by "ceph dashboard iscsi-gateway-add node1 http://admin:admin@192.168.6.3:5000".

the dashboard throw ERROR 500.

the ERROR EXCEPTION IS:

Traceback (most recent call last):↵
File "/usr/lib/python2.7/site-packages/cherrypy/_cprequest.py", line 656, in respond↵ response.body = self.handler()↵
File "/usr/lib/python2.7/site-packages/cherrypy/lib/encoding.py", line 188, in call__↵ self.body = self.oldhandler(*args, **kwargs)↵
File "/usr/lib/python2.7/site-packages/cherrypy/_cptools.py", line 221, in wrap↵ return self.newhandler(innerfunc, *args, **kwargs)↵
File "/usr/share/ceph/mgr/dashboard/services/exception.py", line 88, in dashboard_exception_handler↵ return handler(*args, **kwargs)↵
File "/usr/lib/python2.7/site-packages/cherrypy/_cpdispatch.py", line 34, in _call_↵ return self.callable(*self.args, **self.kwargs)↵
File "/usr/share/ceph/mgr/dashboard/controllers/__init
.py", line 545, in inner↵ ret = func(*args, **kwargs)↵
File "/usr/share/ceph/mgr/dashboard/controllers/__init__.py", line 738, in wrapper↵ return func(*vpath, **params)↵
File "/usr/share/ceph/mgr/dashboard/controllers/iscsi.py", line 105, in list↵ for target_iqn in config['targets'].keys():↵KeyError: 'targets'↵"

QQ图片20190306154828.png View (154 KB) 一帆 师, 03/06/2019 07:54 AM

History

#1 Updated by Ricardo Marques over 3 years ago

Looks like you are using a version of `ceph-iscsi` [1] that is not supported by `ceph-dashboard`.

Upgrading `ceph-iscsi` to the latest master branch should fix the issue.

[1] https://github.com/ceph/ceph-iscsi

#2 Updated by 一帆 师 over 3 years ago

Ricardo Marques wrote:

Looks like you are using a version of `ceph-iscsi` [1] that is not supported by `ceph-dashboard`.

Upgrading `ceph-iscsi` to the latest master branch should fix the issue.

[1] https://github.com/ceph/ceph-iscsi

the rpms in "https://download.ceph.com/ceph-iscsi/latest/rpm/el7/noarch/" are not the lastest?

#3 Updated by 一帆 师 over 3 years ago

Ricardo Marques wrote:

Looks like you are using a version of `ceph-iscsi` [1] that is not supported by `ceph-dashboard`.

Upgrading `ceph-iscsi` to the latest master branch should fix the issue.

[1] https://github.com/ceph/ceph-iscsi

and is there a list of the version of iscsi that ceph-mgr/dashboard supported?

#4 Updated by Ricardo Marques over 3 years ago

一帆 师 wrote:

Ricardo Marques wrote:

Looks like you are using a version of `ceph-iscsi` [1] that is not supported by `ceph-dashboard`.

Upgrading `ceph-iscsi` to the latest master branch should fix the issue.

[1] https://github.com/ceph/ceph-iscsi

the rpms in "https://download.ceph.com/ceph-iscsi/latest/rpm/el7/noarch/" are not the lastest?

Those are outdated, but I don't know where you can find the latest build. Maybe Jason Dillaman can help here.

#5 Updated by Ricardo Marques over 3 years ago

一帆 师 wrote:

Ricardo Marques wrote:

Looks like you are using a version of `ceph-iscsi` [1] that is not supported by `ceph-dashboard`.

Upgrading `ceph-iscsi` to the latest master branch should fix the issue.

[1] https://github.com/ceph/ceph-iscsi

and is there a list of the version of iscsi that ceph-mgr/dashboard supported?

We don't have that documented, yet. For now, we can only guarantee that the latest ceph-dashboard works with the latest ceph-iscsi.

In the future, we would like to have some version checks/validation in the ceph-dashboard, but it's not implemented yet.

#6 Updated by 一帆 师 over 3 years ago

Ricardo Marques wrote:

一帆 师 wrote:

Ricardo Marques wrote:

Looks like you are using a version of `ceph-iscsi` [1] that is not supported by `ceph-dashboard`.

Upgrading `ceph-iscsi` to the latest master branch should fix the issue.

[1] https://github.com/ceph/ceph-iscsi

and is there a list of the version of iscsi that ceph-mgr/dashboard supported?

We don't have that documented, yet. For now, we can only guarantee that the latest ceph-dashboard works with the latest ceph-iscsi.

In the future, we would like to have some version checks/validation in the ceph-dashboard, but it's not implemented yet.

ok,thx for your reply.

I will try to use the github's lastest code then.

#7 Updated by Jason Dillaman over 3 years ago

The latest development releases for CentOS 7 are always available here [1]

[1] https://shaman.ceph.com/repos/ceph-iscsi/master/

#8 Updated by 一帆 师 over 3 years ago

Jason Dillaman wrote:

The latest development releases for CentOS 7 are always available here [1]

[1] https://shaman.ceph.com/repos/ceph-iscsi/master/

the ceph-icsci rpm version in "https://shaman.ceph.com/repos/ceph-iscsi/master/" I found is 2.7-520,but isn't the latest 3.0 ?

I cloned the github code and build the new rpm by ceph-iscsi.spec, and the version in ceph-iscsi.spec defined is 3.0.

so is it means that 2.7-520 and 3.0 both works with mgr-dashboard?

#9 Updated by Jason Dillaman over 3 years ago

There hasn't been a ceph-iscsi 3.0 release yet -- the .spec is just a stub. The auto-builds use the most recent tag as a starting point for the version number.

#10 Updated by Lenz Grimmer over 3 years ago

  • Status changed from New to Won't Fix

Resolving as "Won't fix", as it may have been caused by an outdated version of ceph-iscsi. Please re-open if the error persists with a newer version.

#11 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 141 to Component - iSCSI

Also available in: Atom PDF