Project

General

Profile

Bug #38557

pkg dependency issues upgrading from 12.2.y to 14.x.y

Added by Kaleb KEITHLEY 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
03/03/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Description of problem:
With respect to https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/D4ZBMUAOS63DFEKS4J35EQP5P7VVTPMM/

Upgrading to Fedora 30 fails:

Problem 2: package python-cephfs-1:12.2.11-1.fc29.x86_64 requires libcephfs2 = 1:12.2.11-1.fc29, but none of the providers can be installed
- libcephfs2-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
- problem with installed package python-cephfs-1:12.2.11-1.fc29.x86_64
Problem 3: package python-rados-1:12.2.11-1.fc29.x86_64 requires librados2 = 1:12.2.11-1.fc29, but none of the providers can be installed
- librados2-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
- problem with installed package python-rados-1:12.2.11-1.fc29.x86_64
Problem 4: package python-rbd-1:12.2.11-1.fc29.x86_64 requires librbd1 = 1:12.2.11-1.fc29, but none of the providers can be installed
- librbd1-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
- problem with installed package python-rbd-1:12.2.11-1.fc29.x86_64
Problem 5: package python-rgw-1:12.2.11-1.fc29.x86_64 requires librgw2 = 1:12.2.11-1.fc29, but none of the providers can be installed
- librgw2-1:12.2.11-1.fc29.x86_64 does not belong to a distupgrade repository
- problem with installed package python-rgw-1:12.2.11-1.fc29.x86_64
P
roblem 14: package ceph-mgr-2:14.0.1-4.fc30.x86_64 requires python3-pecan, but none of the providers can be installed
- package python3-pecan-1.3.2-6.fc30.noarch conflicts with python2-pecan < 1.3.2-5 provided by python2-pecan-1.3.2-4.fc29.noarch
- cannot install the best update candidate for package ceph-mgr-1:12.2.11-1.fc29.x86_64
- problem with installed package python2-pecan-1.3.2-4.fc29.noarch
Problem 15: package python-cephfs-1:12.2.11-1.fc29.x86_64 requires libcephfs2 = 1:12.2.11-1.fc29, but none of the providers can be installed
- cannot install both libcephfs2-2:14.0.1-4.fc30.x86_64 and libcephfs2-1:12.2.11-1.fc29.x86_64
- package python-ceph-compat-1:12.2.11-1.fc29.x86_64 requires python-cephfs = 1:12.2.11-1.fc29, but none of the providers can be installed
- cannot install the best update candidate for package libcephfs2-1:12.2.11-1.fc29.x86_64
- problem with installed package python-ceph-compat-1:12.2.11-1.fc29.x86_64

History

#1 Updated by Kaleb KEITHLEY 8 months ago

accidentally opened against bluestore. You may close it.

See https://tracker.ceph.com/issues/38612 instead.

#2 Updated by Nathan Cutler 8 months ago

  • Status changed from New to Closed

Also available in: Atom PDF