Project

General

Profile

Bug #38517

filestore OSDs attempting to come up as bluestore

Added by David Galloway 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
02/28/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

This is after upgrading from 13.2.X to 14.1.0-101-gdddb858

# cat /etc/ceph/osd/115-f721ba5c-d988-4401-b65b-87ec953a6df7.json 
{
    "active": "ok", 
    "type": "filestore", 
    "ceph_fsid": "28f7427e-5558-4ffd-ae1a-51ec3042759a", 
    "cluster_name": "ceph", 
    "data": {
        "path": "/dev/sdb1", 
        "uuid": "f721ba5c-d988-4401-b65b-87ec953a6df7" 
    }, 
    "fsid": "f721ba5c-d988-4401-b65b-87ec953a6df7", 
    "journal": {
        "path": "/dev/disk/by-partuuid/293c2cb5-0ec0-4624-a79b-47fdd54309f3", 
        "uuid": "293c2cb5-0ec0-4624-a79b-47fdd54309f3" 
    }, 
    "journal_uuid": "293c2cb5-0ec0-4624-a79b-47fdd54309f3", 
    "keyring": "AQAk8ENVZiPoBRAAviUeO0fdDGd6SHaaNVZBCA==", 
    "magic": "ceph osd volume v026", 
    "ready": "ready", 
    "systemd": "", 
    "whoami": 115
}

root@mira070:/etc/ceph/osd# /usr/bin/ceph-osd --debug_ms 1 -f --cluster ceph --id 115 --setuser ceph --setgroup ceph
2019-02-28 20:27:14.819 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.819 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.819 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.819 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.819 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.819 7f0a33620f00 -1 bdev(0xc5d4000 /var/lib/ceph/osd/ceph-115/block) open open got: (2) No such file or directory
2019-02-28 20:27:14.819 7f0a33620f00 -1 Falling back to public interface
2019-02-28 20:27:14.887 7f0a33620f00 -1 bdev(0xc5d4000 /var/lib/ceph/osd/ceph-115/block) open open got: (2) No such file or directory
2019-02-28 20:27:14.891 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.891 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115/block) _read_bdev_label failed to open /var/lib/ceph/osd/ceph-115/block: (2) No such file or directory
2019-02-28 20:27:14.891 7f0a33620f00 -1 bluestore(/var/lib/ceph/osd/ceph-115) _mount failed to load os-type: (2) No such file or directory
2019-02-28 20:27:14.891 7f0a33620f00 -1 osd.115 0 OSD:init: unable to mount object store
2019-02-28 20:27:14.891 7f0a33620f00 -1  ** ERROR: osd init failed: (2) No such file or directory

History

#1 Updated by David Galloway 6 months ago

  • Description updated (diff)

#2 Updated by Sage Weil 6 months ago

mira070 is xenial 16.04

#3 Updated by Ken Dreyer 6 months ago

I'm guessing the OSD fails to start for some other reason. systemd ignores settings that it does not know about. The error message could be clearer though.

I can replicate this by adding "Foo=bar" to any .service file.

#4 Updated by Alfredo Deza 6 months ago

  • Project changed from Ceph to ceph-volume

One of the problems here is that `type` is not defined so ceph-volume assumes bluestore (!!!). This shouldn't be the case, and all it would take is to check if json_config.get('journal') is present to set it to filestore, otherwise set it to bluestore

#5 Updated by David Galloway 6 months ago

  • Project changed from ceph-volume to Ceph
  • Subject changed from OSDs fail to come up due to unknown lvalues in systemd unit file to filestore OSDs attempting to come up as bluestore
  • Description updated (diff)

#6 Updated by Sage Weil 6 months ago

  • Status changed from New to Need Review

#7 Updated by Sage Weil 6 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF