Project

General

Profile

Bug #38471

mds does not wait for cap revoke when lock is in LOCK_LOCK_XLOCK state.

Added by Zheng Yan 6 months ago. Updated 5 months ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

shared cap gets revoked during 'LOCK_XLOCKDONE -> LOCK_LOCK_XLOCK' transition.


Related issues

Duplicates fs - Bug #38491: "log [WRN] : Health check failed: 1 clients failing to respond to capability release (MDS_CLIENT_LATE_RELEASE)" Resolved

History

#1 Updated by Zheng Yan 6 months ago

this can cause incorrect warning (pending == issued)

2019-02-25 16:24:15.384411 mds.b [WRN] client.31684173 isn't responding to mclientcaps(revoke), ino 0x30002773f4a pending pAsLsXsFscb issued pAsLsXsFscb, sent 32.058966 seconds ago

#2 Updated by Patrick Donnelly 6 months ago

  • Assignee set to Zheng Yan
  • Priority changed from Normal to High
  • Target version set to v15.0.0
  • Start date deleted (02/25/2019)
  • Source set to Development
  • Backport set to nautilus,mimic,luminous
  • Component(FS) MDS added

#3 Updated by Patrick Donnelly 6 months ago

  • Duplicated by Bug #38491: "log [WRN] : Health check failed: 1 clients failing to respond to capability release (MDS_CLIENT_LATE_RELEASE)" added

#4 Updated by Patrick Donnelly 6 months ago

  • Status changed from New to Verified
  • Priority changed from High to Urgent
  • Target version changed from v15.0.0 to v14.0.0
  • Backport changed from nautilus,mimic,luminous to mimic,luminous

#5 Updated by Zheng Yan 6 months ago

  • Status changed from Verified to Need Review
  • Priority changed from Urgent to High
  • Target version changed from v14.0.0 to v15.0.0
  • Backport changed from mimic,luminous to nautilus,mimic,luminous
  • Pull request ID set to 26713

#6 Updated by Patrick Donnelly 5 months ago

  • Target version changed from v15.0.0 to v14.0.0
  • Backport changed from nautilus,mimic,luminous to mimic,luminous

#7 Updated by Patrick Donnelly 5 months ago

  • Status changed from Need Review to Duplicate
  • Target version deleted (v14.0.0)

Reversing the duplicate since the commit cites the other tracker.

#8 Updated by Patrick Donnelly 5 months ago

  • Duplicates Bug #38491: "log [WRN] : Health check failed: 1 clients failing to respond to capability release (MDS_CLIENT_LATE_RELEASE)" added

#9 Updated by Patrick Donnelly 5 months ago

  • Duplicated by deleted (Bug #38491: "log [WRN] : Health check failed: 1 clients failing to respond to capability release (MDS_CLIENT_LATE_RELEASE)")

Also available in: Atom PDF