Project

General

Profile

Bug #38416

crc cache should be invalidated when posting preallocated rx buffers

Added by Ilya Dryomov almost 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Otherwise, if the buffer was previously checksummed, the client will spin on "bad crc in data" errors forever.


Related issues

Duplicated by RADOS - Bug #40765: mimic: "Command failed (workunit test rados/test.sh)" in smoke/master/mimic Duplicate 07/12/2019
Duplicated by RADOS - Bug #38238: rados/test.sh: api_aio_pp doesn't seem to start Duplicate 02/08/2019
Duplicated by RADOS - Bug #38433: rados/test.sh timeout Duplicate 02/22/2019
Copied to RADOS - Backport #38436: luminous: crc cache should be invalidated when posting preallocated rx buffers Resolved
Copied to RADOS - Backport #38437: mimic: crc cache should be invalidated when posting preallocated rx buffers Resolved

History

#1 Updated by Ilya Dryomov almost 5 years ago

  • Backport set to luminous,mimic

#2 Updated by Ilya Dryomov almost 5 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Sage Weil almost 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler almost 5 years ago

  • Copied to Backport #38436: luminous: crc cache should be invalidated when posting preallocated rx buffers added

#5 Updated by Nathan Cutler almost 5 years ago

  • Copied to Backport #38437: mimic: crc cache should be invalidated when posting preallocated rx buffers added

#6 Updated by Nathan Cutler over 4 years ago

  • Pull request ID set to 26552

#7 Updated by Brad Hubbard over 4 years ago

  • Duplicated by Bug #40765: mimic: "Command failed (workunit test rados/test.sh)" in smoke/master/mimic added

#8 Updated by Neha Ojha over 4 years ago

  • Priority changed from Normal to Urgent

This is causing lots of failures in luminous/mimic, marking it urgent to get the backports expedited.

#9 Updated by Brad Hubbard over 4 years ago

  • Duplicated by Bug #38238: rados/test.sh: api_aio_pp doesn't seem to start added

#10 Updated by Brad Hubbard over 4 years ago

  • Related to Bug #38433: rados/test.sh timeout added

#11 Updated by Brad Hubbard over 4 years ago

  • Related to deleted (Bug #38433: rados/test.sh timeout)

#12 Updated by Brad Hubbard over 4 years ago

  • Duplicated by Bug #38433: rados/test.sh timeout added

#13 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved".

Also available in: Atom PDF