Project

General

Profile

Bug #38390

lvm batch KeyError: 'rotational'

Added by Vasu Kulkarni about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
High
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

http://qa-proxy.ceph.com/teuthology/kchai-2019-02-16_15:31:40-ceph-ansible-wip-sage-testing-2019-02-16-1748-distro-basic-smithi/3601597/teuthology.log

```
2019-02-16T15:54:23.624 INFO:teuthology.orchestra.run.smithi050.stdout:
2019-02-16T15:54:23.625 INFO:teuthology.orchestra.run.smithi050.stdout:TASK [ceph-config : run 'ceph-volume lvm batch --report' to see how many osds are to be created]
2019-02-16T15:54:23.626 INFO:teuthology.orchestra.run.smithi050.stdout:task path: /home/ubuntu/ceph-ansible/roles/ceph-config/tasks/main.yml:22
2019-02-16T15:54:23.626 INFO:teuthology.orchestra.run.smithi050.stdout:Saturday 16 February 2019 15:54:23 +0000 (0:00:00.109) 0:02:00.510 *
*
2019-02-16T15:54:24.930 INFO:teuthology.orchestra.run.smithi050.stdout:fatal: [smithi050.front.sepia.ceph.com]: FAILED! => {
2019-02-16T15:54:24.930 INFO:teuthology.orchestra.run.smithi050.stdout: "changed": true,
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "cmd": [
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "ceph-volume",
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "--cluster",
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "ceph",
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "lvm",
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "batch",
2019-02-16T15:54:24.931 INFO:teuthology.orchestra.run.smithi050.stdout: "--bluestore",
2019-02-16T15:54:24.932 INFO:teuthology.orchestra.run.smithi050.stdout: "--yes",
2019-02-16T15:54:24.932 INFO:teuthology.orchestra.run.smithi050.stdout: "/dev/vg_nvme/lv_4",
2019-02-16T15:54:24.932 INFO:teuthology.orchestra.run.smithi050.stdout: "/dev/vg_nvme/lv_3",
2019-02-16T15:54:24.932 INFO:teuthology.orchestra.run.smithi050.stdout: "/dev/vg_nvme/lv_2",
2019-02-16T15:54:24.932 INFO:teuthology.orchestra.run.smithi050.stdout: "--report",
2019-02-16T15:54:24.932 INFO:teuthology.orchestra.run.smithi050.stdout: "--format=json"
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout: ],
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout: "rc": 1
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout:}
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout:
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout:STDERR:
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout:
2019-02-16T15:54:24.933 INFO:teuthology.orchestra.run.smithi050.stdout:Traceback (most recent call last):
2019-02-16T15:54:24.934 INFO:teuthology.orchestra.run.smithi050.stdout: File "/sbin/ceph-volume", line 9, in <module>
2019-02-16T15:54:24.934 INFO:teuthology.orchestra.run.smithi050.stdout: load_entry_point('ceph-volume==1.0.0', 'console_scripts', 'ceph-volume')()
2019-02-16T15:54:24.934 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/main.py", line 38, in init
2019-02-16T15:54:24.934 INFO:teuthology.orchestra.run.smithi050.stdout: self.main(self.argv)
2019-02-16T15:54:24.934 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/decorators.py", line 59, in newfunc
2019-02-16T15:54:24.934 INFO:teuthology.orchestra.run.smithi050.stdout: return f(*a, **kw)
2019-02-16T15:54:24.935 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/main.py", line 148, in main
2019-02-16T15:54:24.935 INFO:teuthology.orchestra.run.smithi050.stdout: terminal.dispatch(self.mapper, subcommand_args)
2019-02-16T15:54:24.935 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/terminal.py", line 182, in dispatch
2019-02-16T15:54:24.935 INFO:teuthology.orchestra.run.smithi050.stdout: instance.main()
2019-02-16T15:54:24.935 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/devices/lvm/main.py", line 40, in main
2019-02-16T15:54:24.935 INFO:teuthology.orchestra.run.smithi050.stdout: terminal.dispatch(self.mapper, self.argv)
2019-02-16T15:54:24.936 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/terminal.py", line 182, in dispatch
2019-02-16T15:54:24.936 INFO:teuthology.orchestra.run.smithi050.stdout: instance.main()
2019-02-16T15:54:24.936 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/decorators.py", line 16, in is_root
2019-02-16T15:54:24.936 INFO:teuthology.orchestra.run.smithi050.stdout: return func(*a, **kw)
2019-02-16T15:54:24.938 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/devices/lvm/batch.py", line 320, in main
2019-02-16T15:54:24.939 INFO:teuthology.orchestra.run.smithi050.stdout: self._get_strategy()
2019-02-16T15:54:24.939 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/devices/lvm/batch.py", line 291, in _get_strategy
2019-02-16T15:54:24.939 INFO:teuthology.orchestra.run.smithi050.stdout: strategy = get_strategy(self.args, self.args.devices)
2019-02-16T15:54:24.939 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/devices/lvm/batch.py", line 92, in get_strategy
2019-02-16T15:54:24.939 INFO:teuthology.orchestra.run.smithi050.stdout: backend = strategy(devices)
2019-02-16T15:54:24.940 INFO:teuthology.orchestra.run.smithi050.stdout: File "/usr/lib/python2.7/site-packages/ceph_volume/devices/lvm/batch.py", line 44, in bluestore_mixed_type
2019-02-16T15:54:24.940 INFO:teuthology.orchestra.run.smithi050.stdout: types = [device.sys_api['rotational'] for device in device_facts]
2019-02-16T15:54:24.940 INFO:teuthology.orchestra.run.smithi050.stdout:KeyError: 'rotational'
2019-02-16T15:54:24.940 INFO:teuthology.orchestra.run.smithi050.stdout:
```

History

#1 Updated by Vasu Kulkarni about 1 year ago

Just to be clear, the nvme on smithi's are partitions, so its probably better to detect that and create LVs.

#2 Updated by Alfredo Deza about 1 year ago

Hey Vasu, you are passing lvs to batch, which is a bit unexpected. The batch subcommand is supposed to take in raw devices so that the LV creation happens on the fly

#3 Updated by Vasu Kulkarni about 1 year ago

  • Status changed from New to Rejected

sorry closing this out, will check cm-ansible since we have some preconfigurations for smithi which is not needed for ceph-ansible tests.

Also available in: Atom PDF