Project

General

Profile

Bug #38383

compare-and-write skips compare after copyup without object map

Added by Ilya Dryomov 6 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
02/19/2019
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

With object map disabled, a copyup turns compare-and-write into an ordinary write. This is because ObjectOperation::cmpext() claims the passed buffer:

... ObjectCompareAndWriteRequest::add_write_ops(), m_cmp_bl is claimed ...
[stat,set-alloc-hint object_size 4194304 write_size 4194304,cmpext 512~96,write 512~512]
... copyup, is_post_copyup_write_required() -> true ...
... ObjectCompareAndWriteRequest::add_write_ops(), m_cmp_bl is empty ...
[stat,set-alloc-hint object_size 4194304 write_size 4194304,cmpext 512~0,write 512~512]

Since there is no data to compare with, nothing is read and cmpext returns success.

This doesn't happen when object map is enabled because we go straight to the copyup step in that case.


Related issues

Copied to rbd - Backport #38440: luminous: compare-and-write skips compare after copyup without object map Resolved
Copied to rbd - Backport #38441: mimic: compare-and-write skips compare after copyup without object map Resolved

History

#1 Updated by Jason Dillaman 6 months ago

  • Backport set to luminous,mimic

#2 Updated by Jason Dillaman 6 months ago

  • Status changed from In Progress to Pending Backport

#4 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #38440: luminous: compare-and-write skips compare after copyup without object map added

#5 Updated by Nathan Cutler 6 months ago

  • Copied to Backport #38441: mimic: compare-and-write skips compare after copyup without object map added

#6 Updated by Nathan Cutler 3 months ago

  • Pull request ID set to 26519

#7 Updated by Nathan Cutler about 1 month ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF