Project

General

Profile

Feature #38227

mgr/dashboard: Manage PG autoscaling

Added by Lenz Grimmer almost 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Component - Pools
Target version:
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

Ceph Nautilus now supports autoscaling of placement groups: http://docs.ceph.com/docs/master/rados/operations/placement-groups/#autoscaling-placement-groups

When creating or editing a Ceph pool, it should be possible to set the PG autoscaling mode, by allowing a selection box to choose between "on", "off" or "warn" - see the docs for details.

Also, each Pools autoscale status should be displayed when looking at a Pools's details.


Related issues

Related to Dashboard - Bug #35917: mgr/dashboard: Allow the decrease of pg's of an existing pool Resolved
Related to RADOS - Feature #42638: Allow specifying pg_autoscale_mode when creating a new pool Resolved
Related to Dashboard - Feature #40332: mgr/dashboard: Make PGs in pool creation form optional if pg autoscaler is in use Duplicate
Related to Dashboard - Feature #42404: mgr/dashboard: Issue a warning when a replicated pool is created with [min_]size == 1 Resolved
Related to Dashboard - Bug #43102: mgr/dashboard: remove E2E test workaround for autoscaler Resolved
Related to Dashboard - Bug #43980: mgr/dashboard: Use the default pg num instead of "1" when creating a pool with autoscaling enabled New

History

#1 Updated by Lenz Grimmer almost 4 years ago

  • Related to Bug #35917: mgr/dashboard: Allow the decrease of pg's of an existing pool added

#2 Updated by Lenz Grimmer about 3 years ago

  • Target version set to v15.0.0

As there are plans to enable the autoscaler module by default in Octopus, we should review the priority of this one. Setting target version to v15.0.0.

#3 Updated by Ricardo Marques about 3 years ago

  • Assignee set to Ricardo Marques

#4 Updated by Kiefer Chang about 3 years ago

  • Related to Feature #42638: Allow specifying pg_autoscale_mode when creating a new pool added

#5 Updated by Kiefer Chang about 3 years ago

  • Related to Feature #40332: mgr/dashboard: Make PGs in pool creation form optional if pg autoscaler is in use added

#6 Updated by Ricardo Marques about 3 years ago

  • Status changed from New to In Progress

#7 Updated by Lenz Grimmer about 3 years ago

  • Tags set to feature-gap, management

#8 Updated by Lenz Grimmer about 3 years ago

I'm going to resolve #40332 (Make PGs in pool creation form optional if pg autoscaler is in use) as a duplicate of this one, as I assume that this will be addressed in this issue anyway (hiding the PG form when the balancer is enabled).

#9 Updated by Ricardo Marques about 3 years ago

  • Status changed from In Progress to Fix Under Review
  • Pull request ID set to 31417

#10 Updated by Lenz Grimmer about 3 years ago

  • Related to Feature #42404: mgr/dashboard: Issue a warning when a replicated pool is created with [min_]size == 1 added

#11 Updated by Lenz Grimmer about 3 years ago

  • Status changed from Fix Under Review to Resolved

#12 Updated by Patrick Seidensal almost 3 years ago

  • Related to Bug #43102: mgr/dashboard: remove E2E test workaround for autoscaler added

#13 Updated by Lenz Grimmer almost 3 years ago

  • Related to Bug #43980: mgr/dashboard: Use the default pg num instead of "1" when creating a pool with autoscaling enabled added

#14 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 137 to Component - Pools

Also available in: Atom PDF