Project

General

Profile

Bug #38092

mgr/dashboard: incorrect form validation when entering letter into a number input field

Added by Laura Paduano about 4 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
UX
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

During a local test of https://github.com/ceph/ceph/pull/25989 I entered letters into a number input field.
The error message "This field is required" showed up - which does not really fit in that particular case.

Mentioned the issue within the PR and Volker commented on this:
"Interesting issue. The input field is of type 'number', so it does not show chars if you type them, but you can insert them via copy&paste.
On the way down to the form validator the string is converted to something else automatically by Angular, i assume so, because the validator gets a null as value to validate.
So Validator.required does not see the entered value and assumes it is missing => because of that the required error is set. I assume we can not do anything here."

See:
https://github.com/ceph/ceph/pull/25989#issuecomment-457268459
https://github.com/ceph/ceph/pull/25989#issuecomment-457281025

History

#1 Updated by Laura Paduano about 3 years ago

  • Subject changed from mgr/dashboard: incorrect form validation when entering chars into a number input field to mgr/dashboard: incorrect form validation when entering letter into a number input field
  • Description updated (diff)

#2 Updated by Ernesto Puerta almost 2 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 152 to UX

#3 Updated by Sarthak Gupta 7 months ago

this seems to be working fine (tested locally).

#4 Updated by Sarthak Gupta 7 months ago

  • Status changed from New to Closed

Also available in: Atom PDF