Project

General

Profile

Bug #38087

mds: blacklists all clients on eviction

Added by Patrick Donnelly 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Immediate
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:

Description

This is due to the recent messenger overhaul. specifically:

https://github.com/ceph/ceph/blob/7fa1e3c37f8c7fb709ae9e070a3154a7084c0584/src/mds/MDSDaemon.cc#L1309

I believe we should be using get_peer_socket_addr() instead.

Example failure: /ceph/teuthology-archive/pdonnell-2019-01-29_16:26:26-fs-wip-pdonnell-testing-20190129.135650-distro-basic-smithi/3523842/teuthology.log

History

#1 Updated by Patrick Donnelly 8 months ago

  • Status changed from New to In Progress

#2 Updated by Patrick Donnelly 8 months ago

  • Description updated (diff)
  • Status changed from In Progress to Need Review
  • Pull request ID set to 26193

#3 Updated by Patrick Donnelly 8 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF