Project

General

Profile

Bug #37956

qa/workunits/cephtool/test.sh:1124: test_mon_mds: ceph mds stat fails

Added by Sage Weil 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
Start date:
01/17/2019
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

2019-01-17T20:57:38.467 INFO:tasks.workunit.client.0.smithi081.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:782: check_mds_active:  grep active
2019-01-17T20:57:38.786 INFO:tasks.workunit.client.0.smithi081.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1120: test_mon_mds:  ceph fs rm cephfs --yes-i-really-mean-it
2019-01-17T20:57:41.200 INFO:tasks.workunit.client.0.smithi081.stderr:filesystem 'cephfs' does not exist
2019-01-17T20:57:41.218 INFO:tasks.workunit.client.0.smithi081.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1124: test_mon_mds:  ceph mds stat
2019-01-17T20:57:41.456 INFO:tasks.workunit.client.0.smithi081.stderr:no valid command found; 10 closest matches:
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds fail <role_or_gid>
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds repaired <role>
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds set_max_mds <int[0-]>
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds set max_mds|max_file_size|inline_data|allow_new_snaps|allow_multimds|allow_multimds_snaps|allow_dirfrags <val> {--yes-i-really-mean-it}
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds stop <role>
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds deactivate <role>
2019-01-17T20:57:41.457 INFO:tasks.workunit.client.0.smithi081.stderr:mds tell <who> <args> [<args>...]
2019-01-17T20:57:41.458 INFO:tasks.workunit.client.0.smithi081.stderr:mds compat show
2019-01-17T20:57:41.458 INFO:tasks.workunit.client.0.smithi081.stderr:mds count-metadata <property>
2019-01-17T20:57:41.458 INFO:tasks.workunit.client.0.smithi081.stderr:mds versions
2019-01-17T20:57:41.458 INFO:tasks.workunit.client.0.smithi081.stderr:Error EINVAL: invalid command
2019-01-17T20:57:41.466 INFO:tasks.workunit.client.0.smithi081.stderr:/home/ubuntu/cephtest/clone.client.0/qa/workunits/cephtool/test.sh:1: test_mon_mds:  rm -fr /tmp/cephtool.soj
...

/a/sage-2019-01-17_20:24:42-rados-master-distro-basic-smithi/3475133

History

#1 Updated by Patrick Donnelly 8 months ago

From a cursory look, this appears to be because hidden commands are not included in the "get_command_descriptions" list? So the ceph python tool doesn't think the command is valid. From what I can tell, this means hidden commands might as well not exist?

#2 Updated by Sage Weil 8 months ago

  • Status changed from Verified to Need Review

#3 Updated by Patrick Donnelly 8 months ago

  • Assignee set to Patrick Donnelly
  • Target version set to v14.0.0
  • Source set to Q/A
  • Pull request ID set to 26019

#4 Updated by Sage Weil 8 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF