Project

General

Profile

Bug #37873

mgr/dashboard: Cloning modal opens although snapshot isn't protected

Added by Patrick Seidensal about 2 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
dashboard/rbd
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Steps to reproduce:

1. Goto Block -> Images
2. Create an RBD image if there isn't one yet
3. Create a snapshot of that RBD image
4. Select the snapshot of the RBD image and click "Clone"

The Cloning modal will appear but you won't be able to submit the form as the snapshot isn't protected.

Solution:

Disable the menu entry "Clone" if the selected snapshot is not selected.

Screenshot_2019-08-07_17-13-33.png View (58.4 KB) Tatjana Dehler, 08/08/2019 09:21 AM

History

#1 Updated by Patrick Seidensal about 2 years ago

  • Assignee deleted (Patrick Seidensal)

Note: There might be something in the works already that enables clones to be created from unprotected snapshots. Before implementing this issue, it might be worth finding out if it has already been implemented. In that case this issue can simply be closed.

#2 Updated by Jason Dillaman about 2 years ago

For mimic and later, if the "rbd_default_clone_format" configuration setting is set to 1 or if it's set to "auto" and the minimum compatible client is not set to mimic or later -- snapshots would need to be protected since it will use clone format v1. Otherwise, if "rbd_default_clone_format" is set to 2 or if it's set to "auto" and the min compat client is mimic or later, it will use clone format v2 and protecting snapshots is not required.

#4 Updated by Tiago Melo 4 months ago

  • Status changed from New to In Progress
  • Assignee set to Tiago Melo

#5 Updated by Tiago Melo 4 months ago

  • Status changed from In Progress to Fix Under Review
  • Backport set to octopus
  • Pull request ID set to 37416

#6 Updated by Tiago Melo 4 months ago

  • Backport deleted (octopus)

#7 Updated by Lenz Grimmer 3 months ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v16.0.0

Also available in: Atom PDF