Project

General

Profile

Bug #37776

workunits/rados/test_health_warnings.sh fails with <9 osds down

Added by Sage Weil 8 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
12/31/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous,mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

2018-12-29T18:26:19.868 INFO:tasks.workunit.client.0.smithi095.stdout:HEALTH_WARN noup flag(s) set; 8 osds down; 4 hosts (8 osds) down; 2 racks (8 osds) down; 1 row (8 osds) down
2018-12-29T18:26:19.868 INFO:tasks.workunit.client.0.smithi095.stderr:+ ceph health
2018-12-29T18:26:19.868 INFO:tasks.workunit.client.0.smithi095.stderr:+ grep '9 osds'

it's because one of the osds got marked out.

/a/sage-2018-12-29_16:59:10-rados-master-distro-basic-smithi/3405759


Related issues

Copied to RADOS - Backport #37814: mimic: workunits/rados/test_health_warnings.sh fails with <9 osds down Resolved
Copied to RADOS - Backport #37815: luminous: workunits/rados/test_health_warnings.sh fails with <9 osds down Resolved

History

#1 Updated by Sage Weil 8 months ago

  • Status changed from Verified to Need Review

#2 Updated by Kefu Chai 8 months ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #37814: mimic: workunits/rados/test_health_warnings.sh fails with <9 osds down added

#4 Updated by Nathan Cutler 7 months ago

  • Copied to Backport #37815: luminous: workunits/rados/test_health_warnings.sh fails with <9 osds down added

#5 Updated by Nathan Cutler 6 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF