Project

General

Profile

Bug #37745

[test] periodic failure in import_export sparse image test

Added by Jason Dillaman over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Jason Dillaman
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

History

#1 Updated by Jason Dillaman over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#2 Updated by Jason Dillaman over 2 years ago

It appears that the new "access timestamp" logic exposes an existing race condition in the rbd CLI export action. Previously, all librbd callbacks were serialized since only a single thread could invoke the callback (the cache finisher thread or the librados AIO finisher thread if the cache was disabled). Now, if the access timestamp needs to be updated, it's possible for concurrent callbacks to the rbd CLI export logic so the seek operations stomp on one another.

#3 Updated by Jason Dillaman over 2 years ago

  • Pull request ID set to 25883

#4 Updated by Jason Dillaman over 2 years ago

  • Status changed from In Progress to Fix Under Review

#5 Updated by Jason Dillaman over 2 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF