Project

General

Profile

Bug #37448

multisite: sync gets stuck retrying deletes that fail with ERR_PRECONDITION_FAILED

Added by Casey Bodley about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
multisite
Backport:
luminous mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When processing the sync of object deletion, we use an If-UnModified-Since precondition to avoid deleting the local copy of the object if it's changed since the other zone deleted it. Data sync does not handle the ERR_PRECONDITION_FAILED error for this case, though, and treats it as a failure to be retried until success. This results in a data sync shard that gets stuck and can no longer make progress.


Related issues

Copied to rgw - Backport #37550: mimic: multisite: sync gets stuck retrying deletes that fail with ERR_PRECONDITION_FAILED Resolved
Copied to rgw - Backport #37551: luminous: multisite: sync gets stuck retrying deletes that fail with ERR_PRECONDITION_FAILED Resolved

History

#1 Updated by Casey Bodley about 4 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Casey Bodley about 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #37550: mimic: multisite: sync gets stuck retrying deletes that fail with ERR_PRECONDITION_FAILED added

#4 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #37551: luminous: multisite: sync gets stuck retrying deletes that fail with ERR_PRECONDITION_FAILED added

#5 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF