Project

General

Profile

Bug #37432

test_librbd_python.sh fails in luminous-x upgrade test

Added by Kefu Chai 9 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
11/28/2018
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Pull request ID:

Description

rados/upgrade/luminous-x-singleton/{0-cluster/{openstack.yaml start.yaml} 1-install/luminous.yaml 2-partial-upgrade/firsthalf.yaml 3-thrash/default.yaml 4-workload/{rbd-cls.yaml rbd-import-export.yaml readwrite.yaml snaps-few-objects.yaml} 5-workload/{radosbench.yaml rbd_api.yaml} 6-finish-upgrade.yaml 7-mimic.yaml 8-workload/{rbd-python.yaml rgw-swift.yaml snaps-many-objects.yaml} supported-random-distro$/{rhel_latest.yaml} thrashosds-health.yaml}
2018-11-28T03:48:51.413 INFO:tasks.workunit.client.0.smithi142.stderr:======================================================================
2018-11-28T03:48:51.413 INFO:tasks.workunit.client.0.smithi142.stderr:ERROR: test_rbd.test_namespaces
2018-11-28T03:48:51.413 INFO:tasks.workunit.client.0.smithi142.stderr:----------------------------------------------------------------------
2018-11-28T03:48:51.413 INFO:tasks.workunit.client.0.smithi142.stderr:Traceback (most recent call last):
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:  File "/usr/lib/python2.7/site-packages/nose/case.py", line 197, in runTest
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:    self.test(*self.arg)
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:  File "/home/ubuntu/cephtest/clone.client.0/src/test/pybind/test_rbd.py", line 394, in test_namespaces
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:    rbd.namespace_create(ioctx, 'ns1')
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:  File "rbd.pyx", line 1985, in rbd.RBD.namespace_create (/home/jenkins-build/build/workspace/ceph-dev-new-build/ARCH/x86_64/AVAILABLE_ARCH/x86_64/AVAILABLE_DIST/centos7/DIST/centos7/MACHINE_SIZE/huge/r
elease/14.0.1-1182-g6be8f99/rpm/el7/BUILD/ceph-14.0.1-1182-g6be8f99/build/src/pybind/rbd/pyrex/rbd.c:16479)
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:FunctionNotSupported: [errno 38] error creating namespace
2018-11-28T03:48:51.414 INFO:tasks.workunit.client.0.smithi142.stderr:
2018-11-28T03:48:51.415 INFO:tasks.workunit.client.0.smithi142.stderr:----------------------------------------------------------------------
2018-11-28T03:48:51.415 INFO:tasks.workunit.client.0.smithi142.stderr:Ran 135 tests in 551.936s

seems "dir_state_assert" is not available on "rbd" class in luminous OSD yet. can we blacklist this test in the upgrade test?

http://pulpito.ceph.com/kchai-2018-11-28_00:59:04-rados-wip-kefu2-testing-2018-11-27-2345-distro-basic-smithi/3286863/

History

#1 Updated by Mykola Golub 9 months ago

This does not look a problem with "dir_state_assert".

The scenario runs the python test after the full upgrade, that is against the testing branch OSD. And it looks like you are running luminous -> mimic upgrade scenario using a master (nautilus) based branch as the upgrade target. Is it supposed to work? I think the problem in this particular case is that the upgrade scenario sets "require-osd-release mimic" (for nautilus branch) and it makes `rbd_namespace_create` function, which checks for require-osd-release is nautilus, return ENOSYS here.

#2 Updated by Kefu Chai 9 months ago

  • Status changed from New to In Progress
  • Assignee changed from Jason Dillaman to Kefu Chai

agreed. put in another way, we are testing a nautilus feature against a cluster which claims to be mimic compatible.

let me whip up a fix.

#3 Updated by Kefu Chai 9 months ago

  • Status changed from In Progress to Need Review

#4 Updated by Kefu Chai 9 months ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF