Project

General

Profile

Bug #37392

"/usr/bin/ld: cannot find -lradospp" in rados mimic

Added by Yuri Weinstein 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
11/26/2018
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Pull request ID:

Description

Run: http://pulpito.front.sepia.ceph.com/yuriw-2018-11-21_22:16:20-rados-wip-yuri5-testing-2018-11-21-1510-mimic-distro-basic-smithi/
Job: 3278323
Logs: http://qa-proxy.ceph.com/teuthology/yuriw-2018-11-21_22:16:20-rados-wip-yuri5-testing-2018-11-21-1510-mimic-distro-basic-smithi/3278323/teuthology.log

2018-11-21T22:43:54.439 INFO:tasks.workunit.client.0.smithi066.stderr:+ test -f hello_world.cc
2018-11-21T22:43:54.439 INFO:tasks.workunit.client.0.smithi066.stderr:+ for s in '$SOURCES'
2018-11-21T22:43:54.439 INFO:tasks.workunit.client.0.smithi066.stderr:+ test -f Makefile
2018-11-21T22:43:54.439 INFO:tasks.workunit.client.0.smithi066.stderr:+ make all-system
2018-11-21T22:43:54.441 INFO:tasks.workunit.client.0.smithi066.stdout:g++ -std=c++11 -Wno-unused-parameter -Wall -Wextra -Werror -g   -o hello_world_cpp hello_world.cc -lradospp -lradosstriper
2018-11-21T22:43:54.975 INFO:tasks.workunit.client.0.smithi066.stderr:/usr/bin/ld: cannot find -lradospp
2018-11-21T22:43:54.975 INFO:tasks.workunit.client.0.smithi066.stderr:collect2: error: ld returned 1 exit status
2018-11-21T22:43:54.976 INFO:tasks.workunit.client.0.smithi066.stderr:make: *** [hello_world_cpp] Error 1
2018-11-21T22:43:54.976 INFO:tasks.workunit.client.0.smithi066.stderr:+ cleanup
2018-11-21T22:43:54.976 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.976 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/hello_world_c
2018-11-21T22:43:54.977 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.977 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/hello_world_cpp
2018-11-21T22:43:54.978 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.979 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/hello_radosstriper_cpp
2018-11-21T22:43:54.979 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.980 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/hello_radosstriper.cc
2018-11-21T22:43:54.981 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.981 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/hello_world_c.c
2018-11-21T22:43:54.982 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.982 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/hello_world.cc
2018-11-21T22:43:54.983 INFO:tasks.workunit.client.0.smithi066.stderr:+ for f in '$BINARIES$SOURCES'
2018-11-21T22:43:54.983 INFO:tasks.workunit.client.0.smithi066.stderr:+ rm -f /home/ubuntu/cephtest/mnt.0/client.0/tmp/Makefile
2018-11-21T22:43:54.985 DEBUG:teuthology.orchestra.run:got remote process result: 2
2018-11-21T22:43:54.986 INFO:tasks.workunit:Stopping ['rados/test_librados_build.sh'] on client.0...
2018-11-21T22:43:54.986 INFO:teuthology.orchestra.run.smithi066:Running:
2018-11-21T22:43:54.986 INFO:teuthology.orchestra.run.smithi066:> sudo rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/clone.client.0

Related issues

Related to RADOS - Bug #36677: /usr/include/rados/buffer.h:657:61: error: expected ',' before ')' token Resolved 11/01/2018
Copied to Ceph - Backport #37396: mimic: "/usr/bin/ld: cannot find -lradospp" in rados mimic Resolved
Copied to Ceph - Backport #37397: luminous: "/usr/bin/ld: cannot find -lradospp" in rados mimic Resolved

History

#2 Updated by Yuri Weinstein 10 months ago

  • Related to Bug #36677: /usr/include/rados/buffer.h:657:61: error: expected ',' before ')' token added

#3 Updated by Nathan Cutler 10 months ago

  • Status changed from New to In Progress
  • Assignee set to Nathan Cutler

#4 Updated by Nathan Cutler 10 months ago

  • Status changed from In Progress to Need Review
  • Backport set to mimic, luminous
  • Pull request ID set to 25268

#5 Updated by Nathan Cutler 10 months ago

  • Status changed from Need Review to Pending Backport

#6 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #37396: mimic: "/usr/bin/ld: cannot find -lradospp" in rados mimic added

#7 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #37397: luminous: "/usr/bin/ld: cannot find -lradospp" in rados mimic added

#8 Updated by Nathan Cutler 10 months ago

  • Status changed from Pending Backport to Need Review

#9 Updated by Kefu Chai 10 months ago

  • Status changed from Need Review to Pending Backport

#11 Updated by Nathan Cutler 10 months ago

Yuri Weinstein wrote:

We need both mimic and luminous

Both backports are staged and ready for testing.

#12 Updated by Neha Ojha 9 months ago

seen in luminous: /a/yuriw-2018-12-12_16:12:18-rados-wip-yuri-testing-2018-12-10-1551-luminous-distro-basic-smithi/3330488/

#13 Updated by Nathan Cutler 9 months ago

@Neha, @Yuri - the failure mentioned in the previous comment is due to this line:

2018-12-12T16:25:14.792 INFO:tasks.workunit.client.0.smithi008.stderr:+ curl --progress-bar --output Makefile 'http://git.ceph.com/?p=ceph.git;a=blob_plain;f=examples/librados/Makefile'

In other words, this fix (or, more precisely, the luminous backport thereof) was not included in the integration branch.

I'll go ahead and merge the fix now, so this doesn't happen anymore.

#14 Updated by Nathan Cutler 9 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF