Project

General

Profile

Bug #3662

mkcephfs --mkfs is not inserting any default settings

Added by Anonymous over 6 years ago. Updated about 6 years ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/20/2012
Due date:
% Done:

0%

Spent time:
Source:
Development
Tags:
Backport:
Regression:
No
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

It was my understanding that "sudo mkcephfs -a -c ceph.conf -k ceph.keyring --mkfs" would format a device with btrfs (the default) if the ceph.conf file does not have any specific setting for mkfs or mkfs options

I have tried a variety of not defining anything. and they all fail with "No filesystem type defined".

I am filing this as a bug, because we have been told that if nothing is defined, it defaults to btrfs.

easily reproducible.

error:
No filesystem type defined!
fs was not made, nothing mounted

All variations below tested ==========
[osd.2]
host = burnupi41
osd data = /var/lib/ceph/osd/ceph-2
devs = /dev/sdd1
osd mkfs type =
  1. osd mkfs options btrfs =
  2. osd mount options btrfs = ==========
    [osd.11]
    host = burnupi42
    osd data = /var/lib/ceph/osd/ceph-11
    devs = /dev/sde1
    osd mkfs type =
    osd mkfs options btrfs =
    osd mount options btrfs = =============
    [osd.16]
    host = burnupi43
    osd data = /var/lib/ceph/osd/ceph-16
    devs = /dev/sdb1
    osd mkfs type =
    osd mkfs options =
    osd mount options = ============
    [osd.27]
    host = burnupi44
    osd data = /var/lib/ceph/osd/ceph-27
    devs = /dev/sde1
  3. osd mkfs type = btrfs
  4. osd mkfs options btrfs =
  5. osd mount options btrfs =

History

#1 Updated by Dan Mick over 6 years ago

  • Project changed from Linux kernel client to Ceph

#2 Updated by Dan Mick over 6 years ago

The algorithm appears to be

1) if 'devs' is not defined, look for 'btrfs devs'; if that's defined, use those for the
devs to create filesystems on (otherwise, complain 'no devs defined for <name>":

Then, assuming there are devs defined:

2) if 'osd mkfs type' is not defined, look for 'btrfs devs', and if that's defined, use
those devs and set fs_type to btrfs. Otherwise, complain "No filesystem type defined!"

Your text above appears to have been wrapped oddly, but from what I can see, I would have
expected some of those cases to work?...

#3 Updated by Anonymous over 6 years ago

ok, looks like my conf settings got munged.
let's try this again
i was trying to get the mkcephfs to create a default btrfs filesystem (as documented) by not specifying any fs. this did not work at all.

This one I left no entry after "osd mkfs type =", and commented out all options:

[osd.2]
host = burnupi41
osd data = /var/lib/ceph/osd/ceph-2
devs = /dev/sdd1
osd mkfs type =
  1. osd mkfs options btrfs =
  2. osd mount options btrfs =

on osd.11, i just left all the entries blank, but left in the options fstype, btrfs:

[osd.11]
host = burnupi42
osd data = /var/lib/ceph/osd/ceph-11
devs = /dev/sde1
osd mkfs type =
osd mkfs options btrfs =
osd mount options btrfs =

on osd.16, i left all lines blank, but took out the options fstype:

[osd.16]
host = burnupi43
osd data = /var/lib/ceph/osd/ceph-16
devs = /dev/sdb1
osd mkfs type =
osd mkfs options =
osd mount options =

on osd.27, I commented out all the type and options lines....

[osd.27]
host = burnupi44
osd data = /var/lib/ceph/osd/ceph-27
devs = /dev/sde1
  1. osd mkfs type = btrfs
  2. osd mkfs options btrfs =
  3. osd mount options btrfs =

#4 Updated by Anonymous over 6 years ago

anywhere i inserted a hash "#", this lovely program made them into numbered columns, so if you see a block with

x
y
z
1. x
2. y

you should replace the 1 and the 2 with "#" instead.

sigh...
stupid munging code....

#5 Updated by Sage Weil about 6 years ago

  • Status changed from New to Won't Fix

Also available in: Atom PDF