Project

General

Profile

Bug #3646

pg_temp with two down/out osds

Added by Samuel Just over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Monitor
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Encountered on MassEffect, osdmap is attached.

{ "pgid": "2.25",
"osds": [
30,
21]},

Looking over the OSDMonitor code, I don't see anything to remove pg_temp mappings which contain only down/out OSDs. It seems like when we prepare a new map, we should scan pg_temp for any mappings containing only down osds and remove them. Thoughts?

osdmap4 (443 KB) Samuel Just, 12/18/2012 04:41 PM

History

#1 Updated by Sage Weil over 7 years ago

Good point. We can also remove mappings that match the crush result. Although that is a more expensive scan by the monitor.

#2 Updated by Samuel Just over 7 years ago

It actually does that already. OSDMonitor::remove_redundant_pg_temp(). I'll hook in around there for the fix, doing it in apply_incremental would be bad since it would change the result of applying incremental OSDMaps between versions.

#3 Updated by Sage Weil over 7 years ago

sounds exactly right

#4 Updated by Sage Weil over 7 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF