Project

General

Profile

Bug #36398

There is no dependent package in the repository Ubuntu 18.04

Added by Timur Mukhametov about 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
build
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Yesterday, 10.10.2018, the repository https://download.ceph.com/debian-mimic/dists/bionic/main/binary-amd64/ was updated in it there is no python-cephfs 13.2.1 dependent package

photo_2018-10-11_12-16-56.jpg View (45.5 KB) Timur Mukhametov, 10/11/2018 07:17 AM

History

#1 Updated by Bogdan Adrian Velica about 4 years ago

not sure if this is related but I am having some similar issues on a new Ubuntu 16.04 server. apt-get returns some missing dependencies and I cannot install ceph.

steps:
$ wget q -O 'https://download.ceph.com/keys/release.asc' | sudo apt-key add -
$ echo deb https://download.ceph.com/debian-mimic/ $(lsb_release -sc) main | sudo tee /etc/apt/sources.list.d/ceph.list
$ apt-get update && apt-get -y install ceph ceph-osd ceph-mds ceph-mon radosgw

result:
The following packages have unmet dependencies:
ceph : Depends: ceph-mgr (= 13.2.1-1xenial) but it is not going to be installed
ceph-mds : Depends: ceph-base (= 13.2.1-1xenial) but it is not going to be installed
Recommends: libcephfs2 (= 13.2.1-1xenial) but it is not installable
ceph-mon : Depends: ceph-base (= 13.2.1-1xenial) but it is not going to be installed
Recommends: ceph-common but it is not going to be installed
ceph-osd : Depends: ceph-base (= 13.2.1-1xenial) but it is not going to be installed
Recommends: ceph-common (= 13.2.1-1xenial) but it is not going to be installed
radosgw : Depends: ceph-common (= 13.2.1-1xenial) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This did not happened last week.
Maybe the info helps...

#2 Updated by Timur Mukhametov about 4 years ago

Yes, I also tried to put packages from xenial. the problem is reproduced - there are also not enough packages

Luminous is installed without problems. The problem is observed only after yesterday updating the mimic repository

#3 Updated by Ludovic Jerome about 4 years ago

Hi,

+1, can't install ceph mimic on xenial , please see below:

/etc/apt/sources.list.d/ceph.list
  1. This file is managed by Puppet. DO NOT EDIT.
  2. ceph
    deb http://download.ceph.com/debian-mimic/ xenial main

root@frovhcephrgwdev-n03:~# apt install ceph
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
ceph : Dépend: ceph-mgr (= 13.2.1-1xenial) mais ne sera pas installé
Dépend: ceph-mon (= 13.2.1-1xenial) mais ne sera pas installé
Dépend: ceph-osd (= 13.2.1-1xenial) mais ne sera pas installé
Recommande: ceph-mds (= 13.2.1-1xenial) mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

root@frovhcephrgwdev-n03:~# apt install ceph ceph-base ceph-fuse ceph-mds ceph-mgr ceph-mon ceph-osd ceph-common python-cephfs libcephfs2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet libcephfs2 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libcephfs2 » n'a pas de version susceptible d'être installée

#4 Updated by Jeff McLamb about 4 years ago

I believe the problem is that the entire repository is not being listed as available and it is defaulting to Ceph as available in the Ubuntu repos. In the apt-cache policy listing below you will see that it is not picking up on anything in the mimic repos:

$ cat /etc/apt/sources.list.d/ceph.list
deb http://download.ceph.com/debian-mimic bionic main

$ sudo apt update
Hit:1 http://mirrors.mit.edu/ubuntu bionic InRelease
Hit:2 http://mirrors.mit.edu/ubuntu bionic-updates InRelease
Hit:3 http://mirrors.mit.edu/ubuntu bionic-backports InRelease
Hit:4 https://download.docker.com/linux/ubuntu bionic InRelease
Hit:5 http://ppa.launchpad.net/gluster/glusterfs-4.0/ubuntu bionic InRelease
Hit:6 http://mirrors.mit.edu/ubuntu bionic-security InRelease
Hit:7 http://download.ceph.com/debian-mimic bionic InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
75 packages can be upgraded. Run 'apt list --upgradable' to see them.

$ apt-cache policy ceph
ceph:
Installed: (none)
Candidate: 12.2.7-0ubuntu0.18.04.1
Version table:
12.2.7-0ubuntu0.18.04.1 500
500 http://mirrors.mit.edu/ubuntu bionic-updates/main amd64 Packages
12.2.4-0ubuntu1 500
500 http://mirrors.mit.edu/ubuntu bionic/main amd64 Packages

#5 Updated by yi-rui zhu about 4 years ago

Same error from my Ubuntu-1804,

it was worked for installing 13.2.X before 10/10,

but currently, it will just show 12.2.X version on the Ubuntu:

  1. apt-cache policy ceph
    ceph:
    Installed: (none)
    Candidate: 12.2.7-0ubuntu0.18.04.1
    Version table:
    12.2.7-0ubuntu0.18.04.1 500
    500 http://tw.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
    12.2.4-0ubuntu1 500
    500 http://tw.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

#6 Updated by Daniel Austin about 4 years ago

I noticed that today some of the package indexes have been rolled back and some have been updated:

Index of http://download.ceph.com/debian-mimic/dists/xenial/main/binary-amd64/
../
InRelease          15-Oct-2018 17:16     979
Packages           24-Sep-2018 19:08   65839
Packages.bz2       24-Sep-2018 19:08   13900
Packages.bz2.new   10-Oct-2018 18:39    9132
Packages.gz        24-Sep-2018 19:08   15508
Packages.gz.new    10-Oct-2018 18:39    9712
Packages.new       10-Oct-2018 18:39   36325
Release            24-Sep-2018 18:53     111
Release.gpg        15-Oct-2018 17:16     819

I also see now that packages that were missing before are now present:

$ curl -s http://download.ceph.com/debian-mimic/dists/xenial/main/binary-amd64/Packages | grep -E '^Package|^Version' | grep -A1 libcephfs2
Package: libcephfs2
Version: 13.2.2-1xenial
--
Package: libcephfs2-dbg
Version: 13.2.2-1xenial
$ curl -s curl -s http://download.ceph.com/debian-mimic/dists/xenial/main/binary-i386/Packages | grep -E '^Package|^Version' | grep -A1 ceph-deploy
Package: ceph-deploy
Version: 2.0.1

I had to manually delete /var/lib/apt/lists files in order for my systems to see the rolled back Package files since the 'Last-Modified' dates were older than the corrupt indexes that had been cached.

Can we get a fresh index of the files that currently exist in the repo? It seems to me like this is will solve the root cause of the problem.

#7 Updated by Sage Weil over 1 year ago

  • Status changed from New to Closed

Also available in: Atom PDF