Project

General

Profile

Bug #36335

qa: infinite timeout on asok command causes job to die

Added by Patrick Donnelly about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
qa-suite
Labels (FS):
qa, task(easy)
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

e.g.

2018-10-06T06:45:04.574 INFO:teuthology.orchestra.run.smithi130:Running: 'sudo adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage timeout 0 ceph --cluster ceph --admin-daemon /var/run/ceph/ceph-mds.a.asok flush journal'

From: /ceph/teuthology-archive/pdonnell-2018-10-06_01:02:41-fs-wip-pdonnell-testing-20181005.225845-distro-basic-smithi/3106130/teuthology.log

There is a bug in the OSDs preventing the rados ops from completing but the job does not fail because we're using infinite timeouts on the admin socket commands.


Related issues

Copied to CephFS - Backport #36503: mimic: qa: infinite timeout on asok command causes job to die Resolved
Copied to CephFS - Backport #36504: luminous: qa: infinite timeout on asok command causes job to die Resolved

History

#1 Updated by Patrick Donnelly about 4 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Patrick Donnelly about 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #36503: mimic: qa: infinite timeout on asok command causes job to die added

#4 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #36504: luminous: qa: infinite timeout on asok command causes job to die added

#5 Updated by Patrick Donnelly almost 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF