Project

General

Profile

Bug #35847

wrong cluster_network doesn't cause any errors and ends up using monitor network?

Added by Vasu Kulkarni over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Category:
Administration/Usability
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

1) set any random valid cluster network eg: cluster_network: 17.20.20.0/24
2) setup cluster , notice the cluster comes up and doesn't complain anything about wrong osd network

this is misleading to admin and should be fixed, since one believes that cluster network is in use
when it is not

I have tested this in octo lab in luminous, but believe this should exist in master as well, it is easy
to recreate with overrides in teuthology


Related issues

Related to RADOS - Bug #24615: error message for 'unable to find any IP address' not shown Resolved 06/22/2018

History

#1 Updated by Josh Durgin over 2 years ago

  • Category set to Administration/Usability
  • Priority changed from Urgent to High

Agreed, we should have a clear error when one of the networks does not work.

#2 Updated by Victor Denisov over 2 years ago

  • Assignee set to Victor Denisov

#3 Updated by Victor Denisov over 2 years ago

  • Status changed from New to In Progress

#4 Updated by Neha Ojha over 2 years ago

  • Status changed from In Progress to Fix Under Review

#5 Updated by Victor Denisov over 2 years ago

  • Status changed from Fix Under Review to In Progress

Working Greg's comments to my PR.

#6 Updated by Victor Denisov over 2 years ago

  • Related to Bug #24615: error message for 'unable to find any IP address' not shown added

#7 Updated by Victor Denisov over 2 years ago

  • Status changed from In Progress to Fix Under Review

#8 Updated by Sage Weil over 2 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF