Project

General

Profile

Cleanup #35693

Cleanup #35688: mgr/dashboard: Community branding & styling recommendations

Proposed About modal box

Added by Ernesto Puerta almost 2 years ago. Updated 19 days ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/general
Target version:
% Done:

0%

Tags:
Backport:
octopus
Reviewed:
Affected Versions:
Pull request ID:

Description

Current

Proposal

  • Change background color to brand gray (#374249)
  • Add background image (attached below), anchored to bottom/right
  • Ceph icon with full logo on top (attached below)
  • Ceph version laid out differently from downstream since upstream versioning is more verbose
  • A small drop-shadow (#374249), the same color as the background, is applied to all of the text for better readability when the text overlays the background image. Since it is the same color as the background, the drop-shadow is invisible unless the text overlaps the image.

Proposed About Modal

ceph_about_fix.png View - Proposed About Modal (191 KB) Ju Lim, 09/05/2018 03:17 PM

modal_original.jpg View (17.2 KB) Ernesto Puerta, 09/05/2018 03:21 PM

ceph_login_bgimage_fix.png View - Background Image (source: https://unsplash.com/photos/Lu9z9qS8I_Q, free for commercial use) (145 KB) Ernesto Puerta, 09/05/2018 04:44 PM

Ceph_Logo_Standard_RGB_Reversed_120411_fa.png View - https://ceph.com/logos/ (27.5 KB) Ernesto Puerta, 09/05/2018 05:13 PM


Related issues

Copied from mgr - Cleanup #35692: Proposed background color Won't Fix 09/05/2018
Copied to mgr - Backport #45787: octopus: Proposed About modal box Resolved

History

#1 Updated by Ernesto Puerta almost 2 years ago

  • File modal.jpg added
  • Copied from Cleanup #35692: Proposed background color added

#2 Updated by Ernesto Puerta almost 2 years ago

  • File deleted (gray_background.png)

#3 Updated by Ernesto Puerta almost 2 years ago

  • File modal_original.jpg added
  • Description updated (diff)

#4 Updated by Ju Lim almost 2 years ago

#5 Updated by Ju Lim almost 2 years ago

  • File deleted (modal_original.jpg)

#6 Updated by Ju Lim almost 2 years ago

  • File deleted (modal.jpg)

#7 Updated by Ernesto Puerta almost 2 years ago

  • File ceph_about_fix.png added
  • Description updated (diff)

#9 Updated by Ernesto Puerta almost 2 years ago

  • File deleted (ceph_about_fix.png)

#11 Updated by Anonymous almost 2 years ago

What is the version reported here ? I think that the version of the dashboard.
Using the "ceph version" label here could be confusing regarding the ceph versions running on the nodes themselves (osd/mon/etc..).

Maybe replacing "ceph version" by "Version" and aligned with the other items would be more consistent and less confusing.

#12 Updated by Kai Wagner almost 2 years ago

Combined with the Login page Option 2 this lgtm as well.

#13 Updated by Lenz Grimmer over 1 year ago

  • Tags changed from UI to UI, low-hanging-fruit

#14 Updated by Kanika Murarka over 1 year ago

  • Status changed from New to Fix Under Review

#15 Updated by Lenz Grimmer over 1 year ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v14.0.0

#16 Updated by Ngwa Sedrick Meh 3 months ago

Ernesto Puerta wrote:

Current

Proposal

  • Change background color to brand gray (#374249)
  • Add background image (attached below), anchored to bottom/right
  • Ceph icon with full logo on top (attached below)
  • Ceph version laid out differently from downstream since upstream versioning is more verbose
  • A small drop-shadow (#374249), the same color as the background, is applied to all of the text for better readability when the text overlays the background image. Since it is the same color as the background, the drop-shadow is invisible unless the text overlaps the image.

Proposed About Modal

Hi I have worked on this please review the PR here https://github.com/ceph/ceph/pull/34298

#17 Updated by Lenz Grimmer 3 months ago

  • Tags set to low-hanging-fruit
  • Status changed from Resolved to Fix Under Review
  • Target version deleted (v14.0.0)
  • Tags deleted (UI, low-hanging-fruit)
  • Pull request ID set to 34298

#18 Updated by Lenz Grimmer 3 months ago

  • Assignee set to Ngwa Sedrick Meh

#19 Updated by Ngwa Sedrick Meh 3 months ago

  • Pull request ID changed from 34298 to 34336

Update pull request ID

#20 Updated by Ernesto Puerta 3 months ago

  • Pull request ID changed from 34336 to 34298

#21 Updated by Ernesto Puerta 3 months ago

  • Pull request ID changed from 34298 to 34336

#22 Updated by Lenz Grimmer 3 months ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v16.0.0

#23 Updated by Laura Paduano about 1 month ago

  • Status changed from Resolved to Pending Backport
  • Backport set to octopus

#24 Updated by Laura Paduano about 1 month ago

#25 Updated by Laura Paduano about 1 month ago

  • Related to deleted (Backport #45738: mgr/dashboard Proposed About modal box)

#26 Updated by Laura Paduano about 1 month ago

  • Tracker changed from Cleanup to Bug
  • Regression set to No
  • Severity set to 3 - minor

#27 Updated by Laura Paduano about 1 month ago

  • Tracker changed from Bug to Cleanup

#28 Updated by Nathan Cutler about 1 month ago

#29 Updated by Nathan Cutler 19 days ago

  • Status changed from Pending Backport to Resolved

While running with --resolve-parent, the script "backport-create-issue" noticed that all backports of this issue are in status "Resolved" or "Rejected".

Also available in: Atom PDF