Project

General

Profile

Bug #3233

osd: caps in master are incompatible with argonaut caps

Added by Josh Durgin about 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

In argonaut, caps could say 'allow rwx pool=blah', while releases since then have a new parser (from c06e407530c2333022f81ded87013b7e9154e3de) which does not allow '='.

The new parser does not support the '=' in 'pool=blah'.
It also doesn't support uid=blah, but that was undocumented and probably unused.

History

#1 Updated by Josh Durgin about 11 years ago

  • Status changed from 12 to In Progress
  • Assignee set to Josh Durgin

#2 Updated by Josh Durgin almost 11 years ago

  • Category set to OSD
  • Status changed from In Progress to Fix Under Review

The pool=foo support is added again in wip-osd-caps

#3 Updated by Josh Durgin almost 11 years ago

  • Status changed from Fix Under Review to Resolved

This was merged a couple weeks ago.

Also available in: Atom PDF