Project

General

Profile

Bug #308

osd can't get full map history

Added by Greg Farnum over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

10.07.26_20:55:17.810053 7f424cf8d710 osd10 0 handle_osd_map epochs [78,78], i have 0
10.07.26_20:55:17.810093 7f424cf8d710 osd10 0 handle_osd_map already had full map epoch 78
10.07.26_20:55:17.810142 7f424cf8d710 osd10 0 .. it is 4176 bytes
10.07.26_20:55:17.810164 7f424cf8d710 osd10 0 cur 0 < newest 78
10.07.26_20:55:17.810203 7f424cf8d710 osd10 0 handle_osd_map missing epoch 1

Issue seems to occur because the OSD is asking to subscribe to OSDMap epoch 0, which the monitor is interpreting as "most recent."

History

#1 Updated by Sage Weil over 9 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF