Project

General

Profile

Bug #30

multimds: slave_request on getattr

Added by Sage Weil over 9 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/13/2010
Due date:
% Done:

90%

Source:
Tags:
Backport:
Regression:
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

10.04.13 12:39:39.111206 408a7950 -- 10.0.1.245:6802/14233 <== client4122 10.0.1.141:0/3071614701 46048 ==== client_request(client4122:44619 getattr pAsLsXsFs #10000019a2e) ==== 114+0+0 (2100174513 0 0) 0x7f7ea7756a00
10.04.13 12:39:39.111274 408a7950 -- 10.0.1.245:6802/14233 --> mds1 10.0.1.245:6803/14253 -- slave_request(client4122:44619 authpin) -- ?+0 0x7f7e9ced0b00
10.04.13 12:39:39.111500 408a7950 -- 10.0.1.245:6802/14233 <== mds1 10.0.1.245:6803/14253 37920 ==== slave_request(client4122:44619 authpin_ack) ==== 149+0+0 (1483065163 0 0) 0x7f7ea6f0

?

History

#1 Updated by Sage Weil over 9 years ago

  • Category set to 1

#2 Updated by Greg Farnum over 9 years ago

  • Assignee set to Greg Farnum

#3 Updated by Greg Farnum over 9 years ago

  • Assignee deleted (Greg Farnum)

#4 Updated by Sage Weil over 9 years ago

I think the problem is that we authpin anything we rdlock... is that really necessary?

#5 Updated by Sage Weil about 9 years ago

  • Target version set to v0.21

#6 Updated by Sage Weil about 9 years ago

In order to change this, we need a way to wake up the replica waiter when we find out the auth changed, so we can resend the REQRDLOCK. e.g., in handle_export_notify(). there is no infrastructure for that right now.

also need to verify that we resend if we were exporting/importing, and/or the migration aborted. :/

#7 Updated by Sage Weil about 9 years ago

  • Target version changed from v0.21 to v0.22

#8 Updated by Sage Weil about 9 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 50

#9 Updated by Sage Weil about 9 years ago

  • % Done changed from 50 to 90

#10 Updated by Sage Weil about 9 years ago

  • Status changed from In Progress to Resolved

commit:1d8770be2747c43a1aef05a6439b7e23a87f0419

#11 Updated by Sage Weil about 9 years ago

Sigh.. that was a bad decision. Reverted by commit:b7b77ffc1718ea1743e199745e2c55f99ddaa16a, although if we ever go back, a few fixes are in commit:5f6d524df7a20b2d3589226669129eea04739f51.

#12 Updated by John Spray about 3 years ago

  • Project changed from Ceph to fs
  • Category deleted (1)
  • Target version deleted (v0.22)

Bulk updating project=ceph category=mds bugs so that I can remove the MDS category from the Ceph project to avoid confusion.

Also available in: Atom PDF