Project

General

Profile

Bug #2915

rgw: copy of large object times out

Added by Yehuda Sadeh about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

History

#1 Updated by Yehuda Sadeh about 8 years ago

  • Backport set to argonaut

The problem is that apache is timing out. We should return an early 200 and encode any error in the response code, as the S3 specifications describe.

#2 Updated by Yehuda Sadeh about 8 years ago

  • Priority changed from High to Normal
  • Backport deleted (argonaut)

workaround: bump up fastcgi timeout

#3 Updated by Yehuda Sadeh about 8 years ago

  • Target version set to v0.52a

#4 Updated by Yehuda Sadeh about 8 years ago

  • Status changed from New to Fix Under Review

#5 Updated by Yehuda Sadeh about 8 years ago

  • Status changed from Fix Under Review to Duplicate

merged, commit:a16fa0492eaa1f03b8676f8793eaba6fdad21c89

#6 Updated by Yehuda Sadeh about 8 years ago

  • Status changed from Duplicate to Resolved

Also available in: Atom PDF