Project

General

Profile

Bug #29

mds: rfiles underflow

Added by Sage Weil over 9 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature:

Description

[ERR] rfiles underflow -379 on [inode 10002154843 [...2,head] ~mds0/stray/10002154843/ auth v210197041 pv210219007 snaprealm=0x7f756dfb5a80 f(v0 m10.04.13 08:04:13.801599 0=0+0) ds=0=0+0 rb=-98654700(-98654700/-98654700) rf=-379(-379/-379) rd=1(1/1) (iauth sync) (ilink sync) (idft sync) (isnap sync) (inest mix w=1 dirty) (ifile sync) (ixattr sync) (iversion lock) | nref=3 0x7f75537fdd10]

No accompanying debug info, unfortunately.

MDS running on commit:fa9588ab

History

#1 Updated by Sage Weil over 9 years ago

  • Category set to 1

#2 Updated by Sage Weil over 9 years ago

single mds.

#3 Updated by Sage Weil over 9 years ago

  • Status changed from New to Resolved

fixed by commit:8ea9cd5956c7c158fe93076930701927e13bfa03. woot!

#4 Updated by Sage Weil over 9 years ago

  • Status changed from Resolved to New

hit this again on commit:4b6deda44192db6e5a65488ceefa8c0cef2d82df, saved output to fatty:~sage/ceph/src/out.rstat.snap.goof/. looks like a problem with the dirty_old_rstat stuff?

#5 Updated by Sage Weil over 9 years ago

  • Target version set to v0.22

#6 Updated by Sage Weil about 9 years ago

  • Status changed from New to Resolved

Hopefully have this sorted.

#7 Updated by John Spray about 3 years ago

  • Project changed from Ceph to fs
  • Category deleted (1)
  • Target version deleted (v0.22)

Bulk updating project=ceph category=mds bugs so that I can remove the MDS category from the Ceph project to avoid confusion.

Also available in: Atom PDF