Project

General

Profile

Bug #26856

mgr/dashboard: Request body parameters are being encoded and are never decoded

Added by Tiago Melo over 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
General
Target version:
% Done:

0%

Source:
Tags:
Backport:
mimic
Regression:
Yes
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This is a regression introduced in f21d0da5a3e19e3f9bbde084e71b4a09f8dcb0a1.

This is reproducible by trying to create a RBD Snapshot named "a+b".
Out @CdEncode decorator will enconde this string, but since this will be sent over in the body of the request, the backend will never decode it and the creating will fail.
Since there is no actual reason to enconde this, we only need to fix this in the frontend.


Related issues

Copied to Dashboard - Backport #26985: mimic: mgr/dashboard: Request body parameters are being encoded and are never decoded Resolved

History

#2 Updated by Tiago Melo over 4 years ago

  • Status changed from In Progress to Pending Backport

#3 Updated by Nathan Cutler over 4 years ago

  • Copied to Backport #26985: mimic: mgr/dashboard: Request body parameters are being encoded and are never decoded added

#5 Updated by Nathan Cutler about 4 years ago

mimic backport is non-trivial: needs a dashboard developer

#6 Updated by Tiago Melo about 4 years ago

  • Status changed from Pending Backport to Resolved

#7 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 132 to General

Also available in: Atom PDF