Project

General

Profile

Bug #24853

mds: dump recent (memory) log messages before respawning due to being removed from MDSMap

Added by Patrick Donnelly about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Urgent
Category:
Administration/Usability
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If the MDS has been stuck working on something and consequently gets removed from the MDSMap, we'd like to know what it was doing.


Related issues

Copied to CephFS - Backport #25039: luminous: mds: dump recent (memory) log messages before respawning due to being removed from MDSMap Resolved
Copied to CephFS - Backport #25040: mimic: mds: dump recent (memory) log messages before respawning due to being removed from MDSMap Resolved

History

#1 Updated by Patrick Donnelly about 3 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Patrick Donnelly about 3 years ago

  • Category set to Administration/Usability
  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Patrick Donnelly about 3 years ago

  • Copied to Backport #25039: luminous: mds: dump recent (memory) log messages before respawning due to being removed from MDSMap added

#4 Updated by Patrick Donnelly about 3 years ago

  • Copied to Backport #25040: mimic: mds: dump recent (memory) log messages before respawning due to being removed from MDSMap added

#5 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF