Project

General

Profile

Bug #24840

mds: explain delayed client_request due to subtree migration

Added by Patrick Donnelly over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Administration/Usability
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
MDS
Labels (FS):
multimds, task(easy)
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Presently you will see messages like:

slow request 31.064597 seconds old, received at 2018-07-03 13:10:41.645336: client_request(client.108533994:36447167 open #0x1000736c9ab/foo.txt 2018-07-03 13:10:39.817105 caller_uid=1, caller_gid=1{}) currently failed to authpin local pins

We should improve this to diagnose the cause further where possible. In this case, the subtree is frozen and being exported.


Related issues

Copied to CephFS - Backport #26987: luminous: mds: explain delayed client_request due to subtree migration Resolved
Copied to CephFS - Backport #26988: mimic: mds: explain delayed client_request due to subtree migration Resolved

History

#1 Updated by Zheng Yan over 4 years ago

  • Status changed from New to Fix Under Review

#2 Updated by Patrick Donnelly over 4 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler over 4 years ago

  • Copied to Backport #26987: luminous: mds: explain delayed client_request due to subtree migration added

#4 Updated by Nathan Cutler over 4 years ago

  • Copied to Backport #26988: mimic: mds: explain delayed client_request due to subtree migration added

#5 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF