Project

General

Profile

Bug #24674

mgr/dashboard: Unable to disable SSL for proxy environments

Added by Lenz Grimmer over 4 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
General
Target version:
% Done:

0%

Source:
Tags:
dashboard
Backport:
mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When using the Ceph Manager Dashboard behind a proxy server that terminates SSL connections itself, it must be possible to disable the built-in SSL support. Currently, it is not possible to do this.


Related issues

Related to Dashboard - Bug #38528: mgr/dashboard: Unable to disable SSL support Resolved
Copied to Dashboard - Backport #35950: mimic: mgr/dashboard: Unable to disable SSL for proxy environments Resolved

History

#1 Updated by Lenz Grimmer over 4 years ago

Pull Request (thank you Wido!): https://github.com/ceph/ceph/pull/22593

#2 Updated by Lenz Grimmer over 4 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Lenz Grimmer over 4 years ago

  • Assignee changed from Lenz Grimmer to Wido den Hollander

#4 Updated by Ricardo Marques over 4 years ago

  • Status changed from Fix Under Review to Resolved

PR is now merged.

#5 Updated by Alexsander Silva de Souza about 4 years ago

I've noticed this patch was not merged to mimic, and this feature is not present in version 13.2.1.
Will this be backported to Mimic in a future release?

#6 Updated by Lenz Grimmer about 4 years ago

  • Status changed from Resolved to Pending Backport
  • Target version changed from v13.2.1 to v13.2.2

Alexsander Silva de Souza wrote:

I've noticed this patch was not merged to mimic, and this feature is not present in version 13.2.1.

Indeed, thanks for pointing this out.

Will this be backported to Mimic in a future release?

Makes sense. Looks like the bug status was changed to "Resolved" instead of "Pending Backport" by accident.

#7 Updated by Nathan Cutler about 4 years ago

  • Copied to Backport #35950: mimic: mgr/dashboard: Unable to disable SSL for proxy environments added

#8 Updated by Lenz Grimmer about 4 years ago

  • Pull request ID set to 22593

#9 Updated by Sebastian Wagner almost 4 years ago

  • Related to Bug #38528: mgr/dashboard: Unable to disable SSL support added

#10 Updated by Tatjana Dehler over 3 years ago

  • Status changed from Pending Backport to Resolved

#11 Updated by Ernesto Puerta over 1 year ago

  • Project changed from mgr to Dashboard
  • Category changed from 132 to General

Also available in: Atom PDF