Project

General

Profile

Actions

Bug #24621

closed

Ceph Dashboard doesn't support IDs with special characters

Added by Tiago Melo almost 6 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
General
Target version:
% Done:

0%

Source:
Tags:
Backport:
mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

For example, if you have a RBD image named 'foo/bar' the dashboard will return 404 when you try to edit it.
This problem affects the frontend and backend.


Related issues 3 (0 open3 closed)

Related to Dashboard - Bug #24902: Mimic Dashboard does not allow deletion of snapshots containing "+" in their nameResolvedTiago Melo

Actions
Related to Dashboard - Bug #37084: mgr/dashboard: Error when deleting images ending with whitespace in nameCan't reproduce

Actions
Copied to mgr - Backport #24907: mimic: Ceph Dashboard doesn't support IDs with special charactersResolvedTiago MeloActions
Actions #1

Updated by Tiago Melo almost 6 years ago

  • Status changed from In Progress to Fix Under Review
Actions #3

Updated by Lenz Grimmer almost 6 years ago

  • Status changed from Fix Under Review to Resolved
  • Target version set to v14.0.0
Actions #4

Updated by Lenz Grimmer almost 6 years ago

  • Status changed from Resolved to Pending Backport
  • Target version changed from v14.0.0 to v13.2.1
  • Backport set to mimic

Reopening and requesting a backport to Mimic - looks like other strings also have unwanted side-effects - see #24902

Actions #5

Updated by Nathan Cutler almost 6 years ago

  • Copied to Backport #24907: mimic: Ceph Dashboard doesn't support IDs with special characters added
Actions #6

Updated by Nathan Cutler over 5 years ago

Lenz Grimmer wrote:

Reopening and requesting a backport to Mimic - looks like other strings also have unwanted side-effects - see #24902

mimic backport is non-trivial: needs a Dashboard developer

Actions #7

Updated by Tiago Melo over 5 years ago

  • Status changed from Pending Backport to Resolved
Actions #8

Updated by Lenz Grimmer over 5 years ago

  • Related to Bug #24902: Mimic Dashboard does not allow deletion of snapshots containing "+" in their name added
Actions #9

Updated by Lenz Grimmer over 5 years ago

  • Pull request ID set to 22672
Actions #10

Updated by Lenz Grimmer over 5 years ago

  • Related to Bug #37084: mgr/dashboard: Error when deleting images ending with whitespace in name added
Actions #11

Updated by Ernesto Puerta almost 3 years ago

  • Project changed from mgr to Dashboard
  • Category changed from 132 to General
Actions

Also available in: Atom PDF