Project

General

Profile

Bug #24615

error message for 'unable to find any IP address' not shown

Added by Francois Lafont almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Hi,

In my ceph.conf I have the option:

cluster network = 10.0.0.0/24

But the host has no IP address in the network 10.0.0.0/24. This is why my OSD doesn't start:

[root@xceph-nd-2 ~]# /usr/bin/ceph-osd -d --debug_osd 10 --cluster ceph --id 4 --setuser ceph --setgroup ceph
2018-06-22 01:55:14.535 7f28914be1c0  0 set uid:gid to 167:167 (ceph:ceph)
2018-06-22 01:55:14.535 7f28914be1c0  0 ceph version 13.2.0 (79a10589f1f80dfe21e8f9794365ed98143071c4) mimic (stable), process (unknown), pid 21853
2018-06-22 01:55:14.535 7f28914be1c0  0 pidfile_write: ignore empty --pid-file
2018-06-22 01:55:14.572 7f28914be1c0  5 object store type is bluestore

# Above, the exit code is 1 and the osd doesn't start. But there is no relevent error message.

[root@xceph-nd-2 ~]# strace -e trace='!all' /usr/bin/ceph-osd -d --debug_osd 10 --cluster ceph --id 4 --setuser ceph --setgroup ceph
2018-06-22 01:55:24.610 7effcc0b61c0  0 set uid:gid to 167:167 (ceph:ceph)
2018-06-22 01:55:24.610 7effcc0b61c0  0 ceph version 13.2.0 (79a10589f1f80dfe21e8f9794365ed98143071c4) mimic (stable), process (unknown), pid 21866
2018-06-22 01:55:24.611 7effcc0b61c0  0 pidfile_write: ignore empty --pid-file
2018-06-22 01:55:24.659 7effcc0b61c0  5 object store type is bluestore
2018-06-22 01:55:24.662 7effcc0b61c0 -1 unable to find any IP address in networks '10.0.0.0/24' interfaces ''

1. Why the only relevant error message:

unable to find any IP address in networks '10.0.0.0/24' interfaces ''

is displayed only via strace?

2. Is -1 a log level? I thought the log level was N/M where N and M are positive integers.

Regards.


Related issues

Related to RADOS - Bug #35847: wrong cluster_network doesn't cause any errors and ends up using monitor network? Resolved 09/07/2018

History

#1 Updated by Greg Farnum almost 3 years ago

  • Project changed from Ceph to RADOS
  • Category deleted (common)

#2 Updated by Josh Durgin almost 3 years ago

  • Subject changed from The only relevant error message displayed only with strace to error message for 'unable to find any IP address' not shown
  • Priority changed from Normal to High

Sounds like the log isn't being flushed before exiting

#3 Updated by Victor Denisov over 2 years ago

  • Assignee set to Victor Denisov

#4 Updated by Victor Denisov over 2 years ago

  • Related to Bug #35847: wrong cluster_network doesn't cause any errors and ends up using monitor network? added

#5 Updated by Victor Denisov over 2 years ago

  • Status changed from New to Need More Info
  • Assignee changed from Victor Denisov to Francois Lafont

Francois, did you compile your ceph with WITH_SEASTAR option?

#6 Updated by Francois Lafont over 2 years ago

I haven't compiled Ceph: it was installed on CentOS via the RPM Ceph repository (https://download.ceph.com) version 13.2.0.

#7 Updated by Victor Denisov over 2 years ago

  • Assignee changed from Francois Lafont to Victor Denisov

#8 Updated by Victor Denisov over 2 years ago

  • Status changed from Need More Info to In Progress
  • Assignee changed from Victor Denisov to Francois Lafont

#9 Updated by Victor Denisov over 2 years ago

  • Assignee changed from Francois Lafont to Victor Denisov

#10 Updated by Victor Denisov over 2 years ago

  • Status changed from In Progress to Need More Info
  • Assignee changed from Victor Denisov to Francois Lafont

Francois,

Can you try reproducing your issue on the latest master?
I fixed a similar issue in master and also from the error messages I suspect that the source
code has changed significantly and this issue may not be applicable anymore.

Thanks in advance.

#11 Updated by Francois Lafont over 2 years ago

Hi Victor Denisov,

First, really sorry for my late answer (I was a little busy).

In fact, I have tested again with the version 13.2.2 (02899bfda814146b021136e9d8e80eba494e1126) mimic stable without any build from master but via the package directly and now the relevant message is well displayed:

~# /usr/bin/ceph-osd -d --debug_osd 10 --cluster ceph --id 1 --setuser ceph --setgroup ceph
2018-12-11 02:21:28.458 7fa13107d240  0 set uid:gid to 64045:64045 (ceph:ceph)
2018-12-11 02:21:28.458 7fa13107d240  0 ceph version 13.2.2 (02899bfda814146b021136e9d8e80eba494e1126) mimic (stable), process ceph-osd, pid 14396
2018-12-11 02:21:28.458 7fa13107d240  0 pidfile_write: ignore empty --pid-file
2018-12-11 02:21:28.462 7fa13107d240  5 object store type is bluestore
2018-12-11 02:21:28.462 7fa13107d240 -1 unable to find any IP address in networks '10.0.0.0/24' interfaces ''

So the problem seems to be fixed and already released, isn't it? Is is ok for you?

For me it's ok and thx to the team for the fix. :)

#12 Updated by Victor Denisov over 2 years ago

Thanks Francois, I'll close the ticket.

#13 Updated by Victor Denisov over 2 years ago

  • Status changed from Need More Info to Resolved
  • Assignee changed from Francois Lafont to Victor Denisov

Also available in: Atom PDF