Project

General

Profile

Bug #24568

Delete marker generated by lifecycle has no owner

Added by zhang sw over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The delete marker generated by object expiration has no owner associated with it.


Related issues

Copied to rgw - Backport #26847: mimic: Delete marker generated by lifecycle has no owner Resolved
Copied to rgw - Backport #26848: luminous: Delete marker generated by lifecycle has no owner Resolved

History

#2 Updated by Kefu Chai over 4 years ago

  • Status changed from New to In Progress
  • Assignee set to zhang sw

#3 Updated by Kefu Chai over 4 years ago

  • Status changed from In Progress to Fix Under Review

#4 Updated by Kefu Chai over 4 years ago

  • Subject changed from Delete marker generated by lifecycle has no onwer. to Delete marker generated by lifecycle has no owner

#5 Updated by zhang sw over 4 years ago

According to S3, the delete marker should have owner attribute.

#6 Updated by Matt Benjamin over 4 years ago

This change seems logically correct, since delete markers may be deleted by protocol.

https://docs.aws.amazon.com/AmazonS3/latest/dev/RemDelMarker.html

I have not seen any objection thus far.

Matt

#8 Updated by Casey Bodley over 4 years ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to luminous mimic

#9 Updated by Patrick Donnelly over 4 years ago

  • Copied to Backport #26847: mimic: Delete marker generated by lifecycle has no owner added

#10 Updated by Patrick Donnelly over 4 years ago

  • Copied to Backport #26848: luminous: Delete marker generated by lifecycle has no owner added

#11 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF