Project

General

Profile

Bug #24530

Clicking on an OSD which is down will raise an error

Added by Patrick Seidensal about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Category:
dashboard/general
Target version:
-
Start date:
06/15/2018
Due date:
% Done:

100%

Source:
Tags:
dashboard
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Clicking on an OSD which is down will raise an error (errno -6), stating that the OSD is down. We shouldn't raise an error when clicking on an OSD which is rendered in the dashboard as being down. Instead, I'd expect to see the information (blue maybe?) that the attributes, metadata and such cannot be displayed because the OSD is down.

osd-down-error.png View (92.7 KB) Patrick Seidensal, 06/15/2018 12:18 PM

History

#1 Updated by Patrick Seidensal about 1 year ago

  • Tracker changed from Cleanup to Bug
  • Regression set to No
  • Severity set to 3 - minor

#2 Updated by Lenz Grimmer about 1 year ago

Indeed, it would be helpful to highlight down OSDs in the datatable more clearly.

#3 Updated by Lenz Grimmer about 1 year ago

  • Assignee deleted (Lenz Grimmer)
  • Tags set to dashboard

#4 Updated by Patrick Seidensal 12 months ago

  • Status changed from New to In Progress
  • Assignee set to Patrick Seidensal
  • % Done changed from 0 to 30

#5 Updated by Patrick Seidensal 12 months ago

  • % Done changed from 30 to 50

#6 Updated by Patrick Seidensal 12 months ago

  • Status changed from In Progress to Need Review
  • % Done changed from 50 to 90

#8 Updated by Patrick Seidensal 11 months ago

  • Status changed from Need Review to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF