Project

General

Profile

Bug #24427

when no admin key is present, ceph-volume is unable to rollback

Added by Alfredo Deza over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Which is fine, but the error is not enough:

TASK [destroy osd.2] ***********************************************************
task path: /home/jenkins-build/build/workspace/ceph-volume-scenario/src/ceph-volume/ceph_volume/tests/functional/lvm/xenial/bluestore/create/test.yml:11
fatal: [osd0]: FAILED! => {
    "changed": true, 
    "cmd": [
        "ceph", 
        "osd", 
        "destroy", 
        "osd.2", 
        "--yes-i-really-mean-it" 
    ], 
    "delta": "0:00:00.155198", 
    "end": "2018-06-05 22:17:28.064734", 
    "failed": true, 
    "rc": 1, 
    "start": "2018-06-05 22:17:27.909536" 
}

STDERR:

2018-06-05 22:17:28.022 7fa580291700 -1 auth: unable to find a keyring on /etc/ceph/ceph.client.admin.keyring,/etc/ceph/ceph.keyring,/etc/ceph/keyring,/etc/ceph/keyring.bin,: (2) No such file or directory
2018-06-05 22:17:28.046 7fa580291700 -1 monclient: authenticate NOTE: no keyring found; disabled cephx authentication
[errno 95] error connecting to the cluster

MSG:

non-zero return code

In this case, it should say it was unable to rollback the creation of the OSD because there is no admin key.


Related issues

Copied to ceph-volume - Backport #24585: mimic: when no admin key is present, ceph-volume is unable to rollback Resolved
Copied to ceph-volume - Backport #24586: luminous: when no admin key is present, ceph-volume is unable to rollback Rejected

History

#1 Updated by Alfredo Deza over 4 years ago

  • Status changed from New to In Progress

#2 Updated by Sage Weil over 4 years ago

  • Status changed from In Progress to Pending Backport
  • Backport set to mimic,luminous

#3 Updated by Nathan Cutler over 4 years ago

  • Copied to Backport #24585: mimic: when no admin key is present, ceph-volume is unable to rollback added

#4 Updated by Nathan Cutler over 4 years ago

  • Copied to Backport #24586: luminous: when no admin key is present, ceph-volume is unable to rollback added

#5 Updated by Nathan Cutler over 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF