Project

General

Profile

Bug #24365

cosbench stuck at booting cosbench driver

Added by Neha Ojha over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature:

Description

2018-05-30T21:13:05.934 INFO:tasks.cbt:start cosbench
2018-05-30T21:13:05.934 INFO:teuthology.orchestra.run.smithi160:Running: 'cd /home/ubuntu/cephtest && cd cos && sh start-all.sh'
2018-05-30T21:13:06.038 INFO:teuthology.orchestra.run.smithi160.stdout:Launching osgi framwork ...
2018-05-30T21:13:07.040 INFO:teuthology.orchestra.run.smithi160.stdout:Successfully launched osgi framework!
2018-05-30T21:13:07.041 INFO:teuthology.orchestra.run.smithi160.stdout:Booting cosbench driver ...
2018-05-31T08:58:51.232 DEBUG:teuthology.exit:Got signal 15; running 2 handlers...
2018-05-31T08:58:51.275 DEBUG:teuthology.task.console_log:Killing console logger for smithi160
2018-05-31T08:58:51.276 DEBUG:teuthology.task.console_log:Killing console logger for smithi160

http://pulpito.ceph.com/nojha-2018-05-30_20:43:02-rados-wip-async-up2-2018-05-30-distro-basic-smithi/2610583/


Related issues

Copied to RADOS - Backport #24473: mimic: cosbench stuck at booting cosbench driver Resolved

History

#1 Updated by Neha Ojha over 1 year ago

  • Assignee set to Neha Ojha

#2 Updated by Neha Ojha over 1 year ago

  • Subject changed from cosbench stuck after booting cosbench driver to cosbench stuck at booting cosbench driver

#3 Updated by Neha Ojha over 1 year ago

  • Status changed from New to In Progress

Two things caused this issue:

1. cosbench requires openjdk-8. The cbt task does install this dependency, but we also install openjdk-11 for bionic on teuthology. This caused two versions of openjdk to be present.

This can be fixed by removing openjdk-11 via the cbt task.

2. We now need to pass a parameter "-N" to terminate netcat in cosbench-start.sh, because nc no longer terminates on its own, after cosbench finishes sending its active data.

This requires changes to cosbench, and we need to host the compressed version somewhere from where wget can grab it.

#4 Updated by Neha Ojha over 1 year ago

  • Status changed from In Progress to Fix Under Review

#5 Updated by Neha Ojha over 1 year ago

  • Status changed from Fix Under Review to Pending Backport
  • Backport set to mimic

#6 Updated by Nathan Cutler over 1 year ago

  • Copied to Backport #24473: mimic: cosbench stuck at booting cosbench driver added

#7 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF