Project

General

Profile

Bug #24178

test_envlibrados_for_rocksdb.yaml fails installing g++-4.7 on 18.04

Added by Sage Weil about 3 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
mimic, luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2018-05-18T20:23:25.229 INFO:tasks.workunit.client.0.smithi001.stderr:+ sudo apt-get install -y --force-yes automake
2018-05-18T20:23:25.313 INFO:tasks.workunit.client.0.smithi001.stdout:Reading package lists...
2018-05-18T20:23:25.538 INFO:tasks.workunit.client.0.smithi001.stdout:Building dependency tree...
2018-05-18T20:23:25.539 INFO:tasks.workunit.client.0.smithi001.stdout:Reading state information...
2018-05-18T20:23:25.727 INFO:tasks.workunit.client.0.smithi001.stdout:automake is already the newest version (1:1.15.1-3ubuntu2).
2018-05-18T20:23:25.727 INFO:tasks.workunit.client.0.smithi001.stdout:0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded.
2018-05-18T20:23:25.727 INFO:tasks.workunit.client.0.smithi001.stderr:W: --force-yes is deprecated, use one of the options starting with --allow instead.
2018-05-18T20:23:25.727 INFO:tasks.workunit.client.0.smithi001.stderr:+ return 0
2018-05-18T20:23:25.727 INFO:tasks.workunit.client.0.smithi001.stderr:++ pwd
2018-05-18T20:23:25.728 INFO:tasks.workunit.client.0.smithi001.stderr:+ CURRENT_PATH=/home/ubuntu/cephtest/mnt.0/client.0/tmp
2018-05-18T20:23:25.728 INFO:tasks.workunit.client.0.smithi001.stderr:+ case $(lsb_release -si) in
2018-05-18T20:23:25.728 INFO:tasks.workunit.client.0.smithi001.stderr:++ lsb_release -si
2018-05-18T20:23:25.771 INFO:tasks.workunit.client.0.smithi001.stderr:+ install g++-4.7 libgflags-dev libsnappy-dev zlib1g-dev libbz2-dev librados-dev
2018-05-18T20:23:25.771 INFO:tasks.workunit.client.0.smithi001.stderr:+ for package in "$@" 
2018-05-18T20:23:25.771 INFO:tasks.workunit.client.0.smithi001.stderr:+ install_one g++-4.7
2018-05-18T20:23:25.771 INFO:tasks.workunit.client.0.smithi001.stderr:+ case $(lsb_release -si) in
2018-05-18T20:23:25.772 INFO:tasks.workunit.client.0.smithi001.stderr:++ lsb_release -si
2018-05-18T20:23:25.820 INFO:tasks.workunit.client.0.smithi001.stderr:+ sudo apt-get install -y --force-yes g++-4.7
2018-05-18T20:23:25.887 INFO:tasks.workunit.client.0.smithi001.stdout:Reading package lists...
2018-05-18T20:23:26.098 INFO:tasks.workunit.client.0.smithi001.stdout:Building dependency tree...
2018-05-18T20:23:26.098 INFO:tasks.workunit.client.0.smithi001.stdout:Reading state information...
2018-05-18T20:23:26.200 INFO:tasks.workunit.client.0.smithi001.stderr:W: --force-yes is deprecated, use one of the options starting with --allow instead.
2018-05-18T20:23:26.201 INFO:tasks.workunit.client.0.smithi001.stderr:E: Unable to locate package g++-4.7
2018-05-18T20:23:26.201 INFO:tasks.workunit.client.0.smithi001.stderr:E: Couldn't find any package by glob 'g++-4.7'
2018-05-18T20:23:26.201 INFO:tasks.workunit.client.0.smithi001.stderr:E: Couldn't find any package by regex 'g++-4.7'

/a/sage-2018-05-18_16:20:24-rados-wip-sage-testing-2018-05-18-0817-distro-basic-smithi/2548369

Related issues

Copied to Ceph - Backport #40696: mimic: test_envlibrados_for_rocksdb.yaml fails installing g++-4.7 on 18.04 Resolved
Copied to Ceph - Backport #40697: luminous: test_envlibrados_for_rocksdb.yaml fails installing g++-4.7 on 18.04 Resolved

History

#1 Updated by Sage Weil about 3 years ago

  • Backport set to mimic

#2 Updated by Sage Weil about 3 years ago

  • Status changed from 12 to Resolved

#3 Updated by David Zafman about 2 years ago

  • Status changed from Resolved to Pending Backport
  • Assignee set to David Zafman
  • Backport changed from mimic to mimic, luminous

#4 Updated by David Zafman about 2 years ago

  • Pull request ID set to 22103

#5 Updated by David Zafman about 2 years ago

  • Copied to Backport #40696: mimic: test_envlibrados_for_rocksdb.yaml fails installing g++-4.7 on 18.04 added

#6 Updated by David Zafman about 2 years ago

  • Copied to Backport #40697: luminous: test_envlibrados_for_rocksdb.yaml fails installing g++-4.7 on 18.04 added

#7 Updated by Nathan Cutler about 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF